zoukankan      html  css  js  c++  java
  • 【hihocoder】 Magic Box

    题目1 : Magic Box

    时间限制:10000ms
    单点时限:1000ms
    内存限制:256MB

    描述

    The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find what is the maximum number of balls in the box ever.

    For example, let's assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.

    输入

    Line 1: x y z

    Line 2: the sequence consisting of only three characters 'R', 'Y' and 'B'.

    For 30% data, the length of the sequence is no more than 200.

    For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.

    输出

    The maximum number of balls in the box ever.

    提示

    Another Sample

    Sample Input Sample Output
    0 0 0
    RBYRRBY            
    4

    样例输入
    1 2 3
    RRYBRBRYBRY
    样例输出
    7
    #include <string>
    #include <iostream>
    #include <cmath>
    //#include <fstream>
    using namespace std;
    
    int main(){
    
        int r,y,b;
        string s;
        //ifstream cin("in.txt");
        while(cin>>r>>y>>b>>s){
    
            int ans = 0,tmp=0,cr,cy,cb;
            cr = cy = cb = 0;
            for(int i = 0; i < s.size(); ++i){
                tmp++;
                if(s[i] == 'R')   cr++;
                else if(s[i] == 'Y')  cy++;
                else    cb++;
                if(abs(cr - cy) != b)
                    continue;
                if(abs(cr - cb) != y)
                    continue;
                if(abs(cy - cb) != r)
                    continue;
                if(tmp > ans)
                    ans = tmp;
                tmp = 0;
                cr = cy = cb = 0;
            }
            cout << ans << endl;
        }
        return 0;
    }
  • 相关阅读:
    js利用原型对象实现继承--Es5实现的面向对象方式
    js的构造函数原型链
    回调函数
    箭头函数
    关于js的易错知识
    信息论--(1)
    计算机为什么需要反码,补码?
    windows+anaconda下载安装libelimg,学习图像处理
    spring boot + thymeleaf 3 国际化
    spring boot hello and docker
  • 原文地址:https://www.cnblogs.com/zxy1992/p/4392428.html
Copyright © 2011-2022 走看看