zoukankan      html  css  js  c++  java
  • [USACO07MAR]黄金阵容均衡Gold Balanced L… map

    题目描述

    Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

    FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

    Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

    神牛小R在许多方面都有着很强的能力,具体的说,他总共有m种能力,并将这些能力编号为1到m。他的能力是一天一天地提升的,每天都会有一些能力得到一次提升,R对每天的能力提升都用一个数字表示,称之为能力提升数字,比如数字13,转化为二进制为1101,并且从右往左看,表示他的编号为1,3,4的能力分别得到了一次提升。小R把每天表示能力提升的数字的记了下来,如果在连续的一段时间内,小R的每项能力都提升了相同的次数,小R就会称这段时间为一个均衡时期,比如在连续5天内,小R的每种能力都提升了4次,那么这就是一个长度为5的均衡时期。

    于是,问题来了,给出 小R n天的能力提升数字,请求出均衡时期的最大长度。

    【数据规模】对于50%的数据,N <= 1000。

    输入输出格式

    输入格式:

    第一行有两个整数n,m,表示有n天,m种能力。接下来有n行,每行有一个整数,分别表示第1到n天的能力提升数字。能力提升数字转化为二进制后,从右到左的每一位表示对应的能力是否在当天得到了一次提升。

    n<=100000, m<=30

    输出格式:

    输出只有一个整数,表示长度最大的均衡时期的长度。

    输入输出样例

    输入样例#1: 复制
    7 3
    7
    6
    7
    2
    1
    4
    2
    
    输出样例#1: 复制
    4
    
    

    说明

    【样例解释】

    每天被提升的能力种类分别为:

    第一天:1,2,3

    第二天:2,3

    第三天:1,2,3

    第四天:2

    第五天:1

    第六天:3

    第七天:2

    第三天到第六天为长度最长的均衡时期

    因为 这四天 每种能力分别提升了 2次

    可以想到考虑一个前缀和;

    对于均衡区间:

    sum[r]_1-sum[l-1]_1=sum[r]_2-sum[l-1]_2=......=sum[r]_m-sum[l-1]_m;

    我们用 map存入,然后如果在 map中出现了当前的结果 ,更新最大值;

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    //#include<cctype>
    //#pragma GCC optimize(2)
    using namespace std;
    #define maxn 200005
    #define inf 0x7fffffff
    //#define INF 1e18
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-3
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    typedef pair<int, int> pii;
    inline ll rd() {
    	ll x = 0;
    	char c = getchar();
    	bool f = false;
    	while (!isdigit(c)) {
    		if (c == '-') f = true;
    		c = getchar();
    	}
    	while (isdigit(c)) {
    		x = (x << 1) + (x << 3) + (c ^ 48);
    		c = getchar();
    	}
    	return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
    	return b == 0 ? a : gcd(b, a%b);
    }
    int sqr(int x) { return x * x; }
    
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
    	if (!b) {
    		x = 1; y = 0; return a;
    	}
    	ans = exgcd(b, a%b, x, y);
    	ll t = x; x = y; y = t - a / b * y;
    	return ans;
    }
    */
    
    int n, m;
    map<vector<int>, int>mp;
    
    int main() {
    	//ios::sync_with_stdio(0);
    	rdint(n); rdint(m);
    	int ans = 0;
    	vector<int>vc(m);
    	mp[vc] = 0;
    	for (int i = 1; i <= n; i++) {
    		int x; rdint(x);
    		for (int j = 0; j < m; j++) {
    			if (x&(1 << j))vc[j]++;
    		}
    		if (x & 1)for (int j = 0; j < m; j++)vc[j]--;
    		if (mp.count(vc)) {
    			ans = max(ans, i - mp[vc]);
    		}
    		else mp[vc] = i;
    	}
    	cout << ans << endl;
    	return 0;
    }
    
    EPFL - Fighting
  • 相关阅读:
    EELS
    企业管理软件随想透视>包容,无形思想>有形方便
    定风波
    企业管理软件随想也谈企业框架软件需求
    Delphi数据库开发-前言
    游戏引发的……
    js 当前时间
    代码片段
    阶段总结
    Web界面设计
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10267395.html
Copyright © 2011-2022 走看看