zoukankan      html  css  js  c++  java
  • hdu 1211 逆元

    RSA

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2353    Accepted Submission(s): 1677


    Problem Description
    RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

    > choose two large prime integer p, q
    > calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
    > choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
    > calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

    You can encrypt data with this method :

    C = E(m) = me mod n

    When you want to decrypt data, use this method :

    M = D(c) = cd mod n

    Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

    Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
     
    Input
    Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.
     
    Output
    For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
     
    Sample Input
    101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
     
    Sample Output
    I-LOVE-ACM.
     
    Author
    JGShining(极光炫影)
     
    Source
     
     
    解密方式 M=c^d mod n
    c就是题目中给的数字,n=p*q,现在关键是求d,由  d*e≡1 (mod fn)  fn=(p-1)*(q-1),gcd(e,fn)=1,易得d=e-1,只要求出e  mod fn的逆元即可。
    此逆元不能取模fn又很大,所以费马小定理不是很实用,这里采用拓展欧几里得求逆元。
    #include<bits/stdc++.h>
    using namespace std;
    #define LL long long
    #define lld long long
    void exGcd (lld a, lld b, lld &d, lld &x, lld &y)
    {
        if (b == 0)
        {
            x = 1 ;
            y = 0 ;
            d = a ;
            return ;
        }
        exGcd (b, a%b, d, x, y) ;
        lld tmp = x ;
        x = y ;
        y = tmp - a/b*y ;
    }
    LL qpow(LL a,LL b,LL c)
    {
        LL r=1;
        while(b){
            if(b&1) r=r*a%c;
            a=a*a%c;
            b>>=1;
        }
        return r;
    }
    int main()
    {
        LL p,q,e,n,fn,l;
        lld d,x,y;
        while(cin>>p>>q>>e>>l){n=p*q;
                fn=(p-1)*(q-1);
                exGcd(e,fn,d,x,y);
                x=(x%fn+fn)%fn;
            for(int i=1;i<=l;++i){
                LL num;
                scanf("%lld",&num);
                printf("%c",qpow(num,x,n));
            }cout<<endl;
        }
        return 0;
    }

     
     
     
  • 相关阅读:
    路漫漫的自学之路(1)
    feel better about yourself 完美破解MyEclipse 5.5.1 GA 注册码呵呵
    prctise .cpp & .h 的拆分
    JsDemo
    intro
    英汉词典
    曾国藩名言
    挫折
    去掉‘为帮助保护您的安全,internet explorer已经限制此文件显示可能访问您的计算机的活动内容’提示
    曾国藩对联欣赏
  • 原文地址:https://www.cnblogs.com/zzqc/p/7210916.html
Copyright © 2011-2022 走看看