zoukankan      html  css  js  c++  java
  • Anniversary party

    Anniversary party
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9354   Accepted: 5400

    Description

    There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

    Input

    Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
    L K 
    It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
    0 0 

    Output

    Output should contain the maximal sum of guests' ratings.

    Sample Input

    7
    1
    1
    1
    1
    1
    1
    1
    1 3
    2 3
    6 4
    7 4
    4 5
    3 5
    0 0
    

    Sample Output

    5

    Source

     
    题目大意:要开派对 n个人来派对会贡献一定的快乐值 有n-1个关系 K L为L为K的直接上司
    i和他的直接上司不能一起参加派对 求最大的快乐值
     
    题解
    树形dp dp[i][0]为第i个点不去的最大值,dp[i][1]为第i个点去的最大值。
    最后答案为dp[rt][0]和dp[rt][1]的最大值。
     
    代码
    #include<iostream>
    #include<cstdio>
    using namespace std;
    
    int n,x,y,rt;
    int dp[6005][3],dad[6005];
    
    void tree_dp(int now){
        for(int i=1;i<=n;i++)
         if(dad[i]==now){
             tree_dp(i);
             dp[now][1]+=dp[i][0];
             dp[now][0]+=max(dp[i][0],dp[i][1]);
         }
    }
    
    int main(){
        scanf("%d",&n);
        for(int i=1;i<=n;i++)scanf("%d",&dp[i][1]);
        for(int i=1;i<n;i++)scanf("%d%d",&x,&y),dad[x]=y;
        rt=n;
        while(dad[rt])rt=dad[rt];
        tree_dp(rt);
        printf("%d",max(dp[rt][1],dp[rt][0]));
        return 0;
    }
  • 相关阅读:
    算法导论————KMP
    KMP算法
    几个很好的OJ网站
    查找(二分、hash、桶)
    动态规划
    贪心(未完待续)
    搜索的题
    codeVS 1031 质数环
    《将博客搬至CSDN》
    HDU1717小数化分数2
  • 原文地址:https://www.cnblogs.com/zzyh/p/7475878.html
Copyright © 2011-2022 走看看