zoukankan      html  css  js  c++  java
  • 我的第一道java_A+B

    JAVA——A+B

    ——————我的第一道JAVA

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 241566    Accepted Submission(s): 46567


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2 1 2 112233445566778899 998877665544332211
     
    Sample Output
    Case 1:
    1 + 2 = 3
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
     
     大数题,我的第一道JAVA
     
    import java.util.Scanner;
    import java.math.BigInteger;
    
    public class Main {
        final int maxn=1000100;
        public static void main(String[] args){
            Scanner in=new Scanner(System.in);
            int T;
            T=in.nextInt();
            for(int i=1;i<=T;i++){
                BigInteger a,b,c;
                a=in.nextBigInteger();
                b=in.nextBigInteger();
                c=a.add(b);
                System.out.println("Case "+i+":");
                System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
                if(i<T) System.out.println();
            }
        }
    }
    A+B
     
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    wireshark 导出所有filter出来的包
    ubuntu 14.04安装pypcap
    激活windows7 企业版小记
    ubuntu 14.04 以root权限启动chrome
    git clone Linux 源码并切换TAG
    ubuntu 14.04 ns2.35 ***buffer overflow detected **: ns terminated解决办法
    我离baidu.com有几跳
    linux tcp超时重传实现分析
    dpctl 工具使用
    由于log太多导致ubuntu硬盘空间满了,进入不了系统解决办法
  • 原文地址:https://www.cnblogs.com/--560/p/4339871.html
Copyright © 2011-2022 走看看