zoukankan      html  css  js  c++  java
  • poj3292——筛选法

    poj3292——筛选法

    Semi-prime H-numbers
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7772   Accepted: 3360

    Description

    This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

    An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

    As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of twoH-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

    For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

    Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

    Input

    Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

    Output

    For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

    Sample Input

    21 
    85
    789
    0

    Sample Output

    21 0
    85 5
    789 62
    题意:不解释了,自己看吧
    思路:先筛H素数,再筛Hsemi数,最后计数打表
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    
    using namespace std;
    
    const int maxn=1000100;
    const int INF=(1<<28);
    
    int h;
    bool Hprime[maxn];
    bool Hsemi[maxn];
    int ans[maxn];
    
    void play_list()
    {
        memset(Hprime,1,sizeof(Hprime));
        for(int i=5;i<maxn;i+=4){///筛选H素数
            for(int j=5;j<maxn;j+=4){ ///把j的初值改成i就WA。。。因为下面的break使提前退出了?
                int mul=i*j;
                if(mul>=maxn||mul<=0) break;
                Hprime[mul]=0;
            }
        }
        memset(Hsemi,0,sizeof(Hsemi));
        for(int i=5;i<maxn;i+=4){///筛选Hsemi数
            for(int j=5;j<maxn;j+=4){ ///这里也是,把j的初值改成i就WA。。。
                int mul=i*j;
                if(mul>=maxn||mul<=0) break;
                if(Hprime[i]&&Hprime[j]) Hsemi[mul]=1;
            }
        }
        memset(ans,0,sizeof(ans));
        for(int i=1;i<maxn;i++){///打表计数
            if(Hsemi[i]) ans[i]=ans[i-1]+1;
            else ans[i]=ans[i-1];
        }
    }
    
    void debug()
    {
        for(int i=100000;i<=100100;i++){
            cout<<i<<" "<<ans[i]<<endl;
        }
    }
    
    int main()
    {
        play_list();
        //debug();
        while(cin>>h,h){
            cout<<h<<" "<<ans[h]<<endl;
        }
        return 0;
    }
    View Code
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    PhoneGap 的文件 api
    81-POJ-Wall(计算几何)
    12-凸包模板-计算几何
    80-计算几何-奶牛
    79-多边形的面积-计算几何
    78-直线相交-计算几何
    11-欧拉函数详解
    76-Relatives-欧拉函数
    29-中国剩余定理CRT
    2018.3.12 Leecode习题 给定一个整数数列,找出其中和为特定值的那两个数。
  • 原文地址:https://www.cnblogs.com/--560/p/4367520.html
Copyright © 2011-2022 走看看