zoukankan      html  css  js  c++  java
  • Codeforces 679B

    Description

    Limak is a little polar bear. He plays by building towers from blocks. Every block is a cube with positive integer length of side. Limak has infinitely many blocks of each side length.

    A block with side a has volume a3. A tower consisting of blocks with sides a1, a2, …, ak has the total volume a13 + a23 + … + ak3.

    Limak is going to build a tower. First, he asks you to tell him a positive integer X — the required total volume of the tower. Then, Limak adds new blocks greedily, one by one. Each time he adds the biggest block such that the total volume doesn’t exceed X.

    Limak asks you to choose X not greater than m. Also, he wants to maximize the number of blocks in the tower at the end (however, he still behaves greedily). Secondarily, he wants to maximize X.

    Can you help Limak? Find the maximum number of blocks his tower can have and the maximum X ≤ m that results this number of blocks.
    Input

    The only line of the input contains one integer m (1 ≤ m ≤ 1015), meaning that Limak wants you to choose X between 1 and m, inclusive.
    Output

    Print two integers — the maximum number of blocks in the tower and the maximum required total volume X, resulting in the maximum number of blocks.
    Sample Input

    48
    Sample Output

    9 42

    题意

    有一个人在玩堆积木的游戏,给你一个X,这个人会贪心选择一个最大的数,使得这个数a^3<=x,然后堆上去,x-=a^3 然后一直重复这个过程,现在给你一个m,你需要在[1,m]里面找到最大的x,使得使用的数最多,在使用的数最多的情况下,这个数尽量大

    题解:

    dp,每次你有两种决策:对于当前可用的最大的木块a,你可以使用它,剩余的就是m-a^3;你也可以不使用它,那么当前剩余值等于a^3-1,这时就要选择a-1了,剩余价值就是a^3-1-(a-1)^3.
    然后dfs去处理就好了

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    pair<ll,ll> best;
    
    ll pow(ll x){return x*x*x;}
    void dfs(ll m,ll step,ll X)
    {
        if(m==0){
            best=max(best,make_pair(step,X));return;
        }
        ll x=1;
        while(pow(x)<=m)x++;
        x--;
        dfs(m-pow(x),step+1,X+pow(x));
        dfs(pow(x)-1-pow(x-1),step+1,pow(x-1)+X);
    }
    int main()
    {
        ll m;
        cin>>m;
        dfs(m,0,0);
        cout<<best.first<<' '<<best.second;
        return 0;
    }
  • 相关阅读:
    【Hadoop】MapReduce练习:多job关联实现倒排索引
    【Hadoop】MapReduce练习:分科目等级并按分区统计学生以及人数
    【Zookeeper】利用zookeeper搭建Hdoop HA高可用
    【Linux】部署NTP时间同步服务器
    VSCode前端文件以服务器模式打开
    移动端公共方法封装
    常用浏览器及内核
    XHTML和HTML的区别
    javascript算法
    计算属性和侦听器
  • 原文地址:https://www.cnblogs.com/01world/p/5651200.html
Copyright © 2011-2022 走看看