zoukankan      html  css  js  c++  java
  • 数据结构实验之求二叉树后序遍历和层次遍历

    数据结构实验之求二叉树后序遍历和层次遍历

    Time Limit: 1000MS Memory limit: 65536K

    题目描述

     已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

    输入

     输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

    输出

    每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

    示例输入

    2
    abdegcf
    dbgeafc
    xnliu
    lnixu

    示例输出

    dgebfca
    abcdefg
    linux
    xnuli
    
    
    
    
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    typedef struct node
    {
    char data;
    struct node *l,*r;
    }tree;
    tree *creat(char *pre,char *in,int len)/*中序遍历中根节点的左边全都是左子树的中序,右边全是右子树中序。然而每个子树的先序序列的第一个节点是子树的根,而且向后移动中序查找得到的左子树节点数便可分开得到左右子树。因此可以用递归分而治之*/
    {
    tree *head;//创立根节点
    if(len<=0)
    return NULL;//当节点为零时表明数据完全潜入书中
    head = (tree *)malloc(sizeof(tree));
    char *p;

    head->data = *pre;//先序的第一个节点指定是当前子树的根
    for(p = in;p!=NULL;p++)
    if(*p == *pre) break;
    int lon = p-in;//左子树节点的个数
    head->l = creat(pre+1,in,lon);//分而治之创建左子树
    head->r = creat(pre+lon+1,p+1,len-lon-1);//分而治之创建右子树
    return head;
    }
    void cengci(tree *root)
    {
    tree *p[51];//用指针来控制。
    p[0] = root;
    int f = 0,r = 1;
    while(f < r)//每一个p[f]都是子树树根
    {
    if(p[f])//因为为二叉树所以最多有2个子树,且只有当二叉树不为空时才可能有数据,为空时即可跳过,不打印
    {
    printf("%c",p[f]->data);
    p[r++] = p[f]->l;
    p[r++] = p[f]->r;//
    }
    f++;
    }
    }

    last(tree * root)
    {
    if(root)
    {

    last(root->l);
    last(root->r);
    printf("%c",root->data);
    }
    }
    int main()
    {
    int n,i;
    char s0[1000],s1[1000];
    scanf("%d%*c",&n);
    while(n--)
    {
    gets(s0);
    gets(s1);

    char *in,*pre;

    pre = s0,in = s1;
    int len = strlen(s0);//节点数
    tree * root = creat(pre,in,len);//从两个字符串中找出树
    last(root);//后序遍历
    puts("");
    cengci(root);//层次遍历
    puts("");

    }
    return 0;
    }
  • 相关阅读:
    文佳夹之删除
    猜谜小游戏
    python小知识点
    【bzoj4516】[Sdoi2016]生成魔咒 后缀数组+倍增RMQ+STL-set
    【bzoj3362/3363/3364/3365】[Usaco2004 Feb]树上问题杂烩 并查集/树的直径/LCA/树的点分治
    【poj1741】Tree 树的点分治
    【bzoj2946】[Poi2000]公共串 后缀数组+二分
    【bzoj2157】旅游 树链剖分+线段树
    【bzoj2743】[HEOI2012]采花 树状数组
    【bzoj2705】[SDOI2012]Longge的问题 欧拉函数
  • 原文地址:https://www.cnblogs.com/0803yijia/p/2381198.html
Copyright © 2011-2022 走看看