zoukankan      html  css  js  c++  java
  • POJ 3009 深搜 Curling 2.0

     
    Curling 2.0
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8062   Accepted: 3337

    Description

    On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

    Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

    Fig. 1: Example of board (S: start, G: goal)

    The movement of the stone obeys the following rules:

    • At the beginning, the stone stands still at the start square.
    • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
    • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
    • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
      • The stone hits a block (Fig. 2(b), (c)).
        • The stone stops at the square next to the block it hit.
        • The block disappears.
      • The stone gets out of the board.
        • The game ends in failure.
      • The stone reaches the goal square.
        • The stone stops there and the game ends in success.
    • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.

    Fig. 2: Stone movements

    Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

    With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

    Fig. 3: The solution for Fig. D-1 and the final board configuration

    Input

    The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

    Each dataset is formatted as follows.

    the width(=w) and the height(=h) of the board First row of the board ... h-th row of the board

    The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

    Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

    0 vacant square
    1 block
    2 start position
    3 goal position

    The dataset for Fig. D-1 is as follows:

    6 6 1 0 0 2 1 0 1 1 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 1 0 0 0 0 1 0 1 1 1 1 1

    Output

    For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

    Sample Input

    2 1
    3 2
    6 6
    1 0 0 2 1 0
    1 1 0 0 0 0
    0 0 0 0 0 3
    0 0 0 0 0 0
    1 0 0 0 0 1
    0 1 1 1 1 1
    6 1
    1 1 2 1 1 3
    6 1
    1 0 2 1 1 3
    12 1
    2 0 1 1 1 1 1 1 1 1 1 3
    13 1
    2 0 1 1 1 1 1 1 1 1 1 1 3
    0 0

    Sample Output

    1
    4
    -1
    4
    10
    -1
    代码 :
    #include<cstdio>
    #include<iostream>
    using namespace std ;
    #define M 130
    int cap[M][M] , step ;
    bool ok ;
    int sx , sy , ex , ey , n , m;
    int xx[4] = { 1 , -1 , 0 , 0 } , yy[4] = { 0 , 0 , -1 , 1 } ;
    void dfs( int s , int e , int sum ) {
    	int i , j , x , y ;
    	
    	if( sum >= 10 ) return ;
    	for( i = 0 ; i < 4 ; i++){
    		
    			x = s ; y = e ;
    		if( cap[x+xx[i]][y+yy[i]] != 1 ){
    		     
    			while( cap[x+xx[i]][y+yy[i]] != 1 ){ // zhuyixianhou 
    				if( x == ex && y == ey ){
    					ok = 1 ;
                        if( sum + 1 < step ) 
    						step = sum + 1 ;
    					return ;
    				}
    				x += xx[i] ; y += yy[i] ;
    				
    				if( x <= 0 || y <= 0 || x > n || y > m ) 
    					break ;
    			}
    			 
    			if( x >= 1 && y >= 1 && x <= n && y <= m && sum + 1 < 10){
    				cap[x+xx[i]][y+yy[i]] = 0 ;
    				dfs( x , y , sum + 1 ) ;
    				cap[x+xx[i]][y+yy[i]] = 1 ;
    			}
    			
    		}
    	}
    }
    int main()
    {
    	int i , j  ;
    	while( cin >> m >> n ){
    		if( m == 0 && n == 0 ) break ;
    		ok = 0 ;
    		memset( cap , 0 , sizeof(cap) ) ;
    		for( i = 1 ;i <= n ; i++)
    			for( j = 1 ; j <= m ;j++)
    			{
                          scanf( "%d" , &cap[i][j] ) ;
    					  if(cap[i][j] == 2 ){ sx = i ; sy = j ; }
    					  else if( cap[i][j] == 3 ){ ex = i ; ey = j ; }
    			}
    			 step = 2994466 ;
    			 dfs( sx , sy , 0 ) ;
    			 if( ok ) cout << step << endl ;
    			 else cout << "-1" << endl ;
    	}
    }
    

      

  • 相关阅读:
    EasyRadius 动态域名DDNS设置工具,支持WayOS三代,完美解决近段时间3322和每步不稳定问题
    爱快路由计费系统easyradius隆重发布,支持V2版本,欢迎大家测试使用
    easyradius隆重发布ROS API计费接口,支持ROS 3.3以上版本,实现简单快捷的ROS宽带计费系统云端版
    easyradius通讯接口 V4全新升级,显示同步失败原因,方便用户寻找故障
    上网爱快?EasyRadius FOR 爱快V2接口测试版正式推出,欢迎广大爱迷们测试噢
    让小区运营再智能一点,EasyRadius正式向WayOs用户提供到期弹出式提示充值页面
    Easyradius对接WayOs维盟小区版XQ教程
    由于PADT伪造攻击带来的大面积掉线原因分析
    WiFidog 广告路由可修改功能更加智能化的几点看法
    TFTP 1.68智能刷机全能版发布,TTL线在CFE模式解决BCM5357如斐讯FIR302B等产品变砖问题
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3028220.html
Copyright © 2011-2022 走看看