zoukankan      html  css  js  c++  java
  • 3006 HDU The Number of set

    http://www.cnblogs.com/lonelycatcher/archive/2011/05/27/2060158.html

    Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
     
    Input
    There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
     
    Output
    For each case,the output contain only one integer,the number of the different sets you get.
     
    Sample Input
    4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
     
    Sample Output
    15 2
    //第一次接触这种题目网上说是状态压缩DP。
    '|'的运算,
    集合 中的元素当成是 2进制中的名次, 比如1 2 3 代表 111。 1 3代表101。这样就可以求出集合的个数了
    不过感觉有点小疑问,题目说的是新组成的集合,但是算的时候却包含了本来的,这个就、、、

    #include <iostream>
    #include <string.h>
    #include <cstdio>
    using namespace std;
    int hash[1<<15];
    int main()
    {  // freopen("in.txt","r",stdin);
        int n,m,k,i,x,y;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            memset(hash,0,sizeof(hash));
            m=1<<m;
            while(n--)
               {
                   scanf("%d",&k);
                   y=0;//开始时y=0写到上面去了,郁闷,
                   while(k--)
                   {
                    scanf("%d",&x);
                    y=y|(1<<(x-1));
                   }
                 hash[y]=1;
                 for(i=0;i<=m;i++)
                  if(hash[i])
                    hash[i|y]=1;  //算是得到新集合吧
               }n=0;


            for(i=0;i<=m;i++)
              if(hash[i])
              n++;
            printf("%d\n",n);
        }
        return 0;
    }

  • 相关阅读:
    Action<T>和Func<T>的使用(转)
    javascript将网页表格导出Word(转载)
    jQuery扩展方法2(转载)
    Microsoft SQL Server 2008 安装说明
    INSERT INTO 语句的语法错误 access 保留字段
    .NET 验证控件
    TFS强制撤销用户的签出
    .net 操作XML
    TFS 恢复删除文件
    checkboxlist详细用法、checkboxlist用法、checkboxlist
  • 原文地址:https://www.cnblogs.com/372465774y/p/2423690.html
Copyright © 2011-2022 走看看