zoukankan      html  css  js  c++  java
  • F

    Description

    There is a hill with n holes around. The holes are signed from 0 to n-1.



    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

    Input

    The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

    Output

    For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

    Sample Input

    2
    1 2
    2 2

    Sample Output

    NO
    YES


    题目大意:有0到n-1个洞,狼从0开始找,然后隔m个依次往右寻找,n为小白兔所在的位置,现在让我们判断小白兔是否安全。
    就是求最大公约数。有方向就好办了。

    代码如下:
    #include<cstdio>
    int main()
    {
       long long m,n,t,temp;
        scanf("%d",&t);
         while(t--)
         {
              scanf("%lld%lld",&m,&n);
              while(n!=0)
              {
                   temp=n;
                   n=m%n;
                   m=temp;
              }
         if(m==1)printf("NO ");
         else printf("YES ");
         }
         return 0;
    }

  • 相关阅读:
    vscode识别预览markdown文件
    工具:静态资源服务器server
    vscode配置easy sass 生成压缩和未压缩的css文件
    cocos Create简单记录
    小程序AR云识别
    小程序被冻结 解冻方法
    vscode设置px转换为rem
    js 打印文本
    .net 启动进程并执行某方法
    c# 创建文件夹、压缩成zip格式并下载
  • 原文地址:https://www.cnblogs.com/441179572qqcom/p/5743545.html
Copyright © 2011-2022 走看看