zoukankan      html  css  js  c++  java
  • poj 3349 Snowflake Snow Snowflakes

    Description

    You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

    Input

    The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

    Output

    If all of the snowflakes are distinct, your program should print the message:
    No two snowflakes are alike.
    If there is a pair of possibly identical snow akes, your program should print the message:
    Twin snowflakes found.

    Sample Input

    2
    1 2 3 4 5 6
    4 3 2 1 6 5

    Sample Output

    Twin snowflakes found.

    Source

     
    hash表。
    代码:
    #include <iostream>
    #include <cstdlib>
    #include <cstdio>
    #include <cstring>
    #include <vector>
    #define mod 99989
    using namespace std;
    
    int n,flag;
    vector<int> Hash[100000];
    int snow[100000][6];
    bool check(int a,int b) {
        for(int i = 0;i < 6;i ++) {
            if(snow[a][i] != snow[b][0]) continue;
            int j;
            for(j = 0;j < 6;j ++) {
                if(snow[a][(i + j) % 6] != snow[b][j]) break;
            }
            if(j == 6) return true;
            for(j = 0;j < 6;j ++) {
                if(snow[a][(i - j + 6) % 6] != snow[b][j]) break;
            }
            if(j == 6) return true;
        }
        return false;
    }
    int main() {
        scanf("%d",&n);
        for(int i = 0;i < n;i ++) {
            int d = 0;
            for(int j = 0;j < 6;j ++) {
                scanf("%d",&snow[i][j]);
                d = (d + snow[i][j]) % mod;
            }
            if(flag) continue;
            Hash[d].push_back(i);
            for(int j = 0;j < Hash[d].size() - 1;j ++) {
                flag = check(Hash[d][j],i);
                if(flag) break;
            }
        }
        puts(flag ? "Twin snowflakes found." : "No two snowflakes are alike.");
    }
  • 相关阅读:
    【go语言学习】标准库之sync
    【go语言学习】并发实现
    【go语言学习】并发概念
    【html学习】html基础
    【go语言学习】错误error和异常panic
    【go语言学习】type关键字
    【go语言学习】面向对象oop
    【go语言学习】接口interface
    【go语言学习】结构体struct
    【go语言学习】指针pointer
  • 原文地址:https://www.cnblogs.com/8023spz/p/10769961.html
Copyright © 2011-2022 走看看