zoukankan      html  css  js  c++  java
  • A Corrupt Mayor's Performance Art

    Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

    Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

    The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

    This was the secretary's idea:

    The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

    But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

    InputThere are several test cases.

    For each test case:

    The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

    Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

    1) P a b c
    a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

    2) Q a b
    a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

    Please note that the operations are given in time sequence.

    The input ends with M = 0 and N = 0.OutputFor each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.Sample Input
    5 10
    P 1 2 3
    P 2 3 4
    Q 2 3
    Q 1 3
    P 3 5 4
    P 1 2 7
    Q 1 3
    Q 3 4
    P 5 5 8
    Q 1 5
    0 0
    Sample Output
    4
    3 4
    4 7
    4
    4 7 8

    线段树 + 位运算,注释写的很多,因为不是很会线段树,总是写崩,逻辑要搞清楚。32位int正好可以存30种颜色的状态,存在第几个颜色就把第几位变为1.

    代码:

    ///color n 用位移 1 << n来记录
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <cmath>
    #include <stack>
    #define lson l,mid,t << 1
    #define rson mid + 1,r,t << 1 | 1
    using namespace std;
    
    int tree[4000005];
    int lazy[4000005];///初始为0 表示原来是什么颜色 当更新的区间只占子树一部分时 拆分子树向下更新lazy 无关的区间不受影响,只更新范围内的区间
    
    void build(int l,int r,int t)
    {
        lazy[1] = 1 << 2;
        tree[t] = 1 << 2;///The wall's original color was color 2
        if(l == r)return;///线段树的叶节点
        int mid = (l + r) >> 1;///从中间分成左右子树
        build(lson);
        build(rson);
    }
    void update(int L,int R,int col,int l,int r,int t)///更新
    {
        if(r < L || l > R)return;///无交集
        if(l >= L && r <= R)///当前子树处于查询范围内
        {
            lazy[t] = 1 << col;
            tree[t] = 1 << col;
            return;
        }
        if(lazy[t])///当前子树的颜色都是lazy[t] 向下更新 如果值是0,表示左右子树本来就不一致
        {
            lazy[t << 1] = lazy[t << 1 | 1] = lazy[t];
            tree[t << 1] = tree[t << 1 | 1] = tree[t];
            lazy[t] = 0;///当前子树里的颜色已经不是全都一致的了
        }
        int mid = (l + r) >> 1;
        update(L,R,col,lson);///当前子树只有左子树需要更新
        update(L,R,col,rson);///当前子树只有右子树需要更新
    
        tree[t] = tree[t << 1] | tree[t << 1 | 1];///向上更新  位或操作合并状态
    }
    int query(int L,int R,int l,int r,int t)///查询
    {
        if(l > R || r < L)return 0;///不再区间内返回0 表示没颜色
        if(l >= L && r <= R || lazy[t])///子树在查询区间内 或者子树状态一致 直接返回
        {
            return tree[t];
        }
        int mid = (l + r) >> 1;
        return query(L,R,lson) | query(L,R,rson);///返回颜色状态的并集
    }
    int main()
    {
        int n,m,a,b,c;
        char ch[2];
        while(~scanf("%d%d",&n,&m)&&(n + m))
        {
            build(1,n,1);///建树
            while(m --)
            {
                scanf("%s",ch);
                if(ch[0] == 'P')
                {
                    scanf("%d%d%d",&a,&b,&c);
                    update(a,b,c,1,n,1);
                }
                else
                {
                    scanf("%d%d",&a,&b);
                    int ans = query(a,b,1,n,1),flag = 0;
                    for(int i = 1;i <= 30;i ++)
                    if((ans >> i) & 1)
                    {
                        if(flag)printf(" %d",i);
                        else
                        {
                            flag = 1;
                            printf("%d",i);
                        }
                    }
                    putchar('
    ');
                }
            }
        }
    }
  • 相关阅读:
    css3 让一个图片翻转示例代码
    万能清除法
    str_replace 字符串匹配替换 explode 拆分字符串成数组 implode 数组 为字符串 list($month, $day, $year) = split ('[/.-]', $date);
    历年沪深A股、香港H股票数据导入和实时数据更新展示 ---转载
    CSS3生成音频波纹效果加载中动画
    jQuery中Ajax快捷方法之$.getScript()
    jQuery中Ajax快捷方法之$.get()
    ajax 关于IP地址查询的API
    php 拒绝用户输入非法字符
    PHP 字符串函数是 PHP 核心的组成部分。
  • 原文地址:https://www.cnblogs.com/8023spz/p/7787574.html
Copyright © 2011-2022 走看看