zoukankan      html  css  js  c++  java
  • -------Pokemon Master------很水-------

    A - Pokemon Master
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
    Submit
     
    Status
    Description
    Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each's team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!
    
    Input
    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
    
    The first line contains two integers N and M (1 <= N, M <= 6), which describes that Calem has N pokemons and Serena has M pokemons.
    
    The second line contains N integers indicating the weight of Calem's pokemons. The third line contains M integers indicating the weight of Serena's pokemons. All pokemons' weight are in the range of [1, 2094] pounds.
    
    Output
    For each test case, output "Calem" if Calem's team will win the battle, or "Serena" if Serena's team will win. If the two team have the same total weight, output "Draw" instead.
    
    Sample Input
    1
    6 6
    13 220 199 188 269 1014
    101 176 130 220 881 396
    Sample Output
    Serena

    臭长题目其实没有多少技术含量.

    意思就是  第一行数据是测试案例数.  第二行是   每个人拥有的拥有的什么鬼东西的重量,让你求出分别拥有的重量之和,谁的大谁就赢了.平局的话输出平局.

    #include<stdio.h>
    int main()
    {
        int t, n, m;
        scanf("%d", &t);
        while (t--)
        {
            scanf("%d %d", &n, &m);
            int i, num, s1 = 0, s2 = 0;
            for (i = 0; i < n; i++)
            {
                scanf("%d", &num);
                s1 += num;
            }
            for (i = 0; i < m; i++)
            {
                scanf("%d", &num);
                s2 += num;
            }
            if (s1 == s2)
                printf("Draw");
            else
                printf(s1 > s2 ? "Calem" : "Serena");   //这里运用了三目运算符   很节省篇幅.......值得学习,如果?之前的条件成立的话,就执行紧挨着的,否则就执行:后面的
        }
        return 0;
    }
  • 相关阅读:
    RSS简易阅读器vb.net源代码
    [建议]有关图片地址的建议
    [音乐欣赏]wind flowers
    有个叫计算机的比我笨
    一个朋友画的建筑设计手绘图与其想到的
    [推荐]华建小翻--QQ里的一个不错的服务商
    爆强的广告
    [学习日记]重构简易RSSREADER的UML类图
    [音乐欣赏]红颜
    [音乐欣赏]花与琴的流星
  • 原文地址:https://www.cnblogs.com/A-FM/p/5096615.html
Copyright © 2011-2022 走看看