zoukankan      html  css  js  c++  java
  • 7-17 Hashing(25 分)

    Hashing

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:
    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10^4)

    ​​and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:
    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -
    

    分析

    从本题给的样例输出可以看出本题使用平方探测法

    代码如下

    #include<iostream>
    #include<math.h>
    using namespace std;
    int IsPrime(int n)
    {
        if(n <= 1) return 0;
        for(int i=2;i<=sqrt(n);i++)
        if(n%i==0) 
        return 0;	
        return 1;
    }
    int NextPrime(int n)
    {
        while(!IsPrime(n))n++;
        return n;
    }
    int main(){
    	int m,n,tblsize,t,p;
    	cin>>m>>n;
    	tblsize=NextPrime(m);
            int pos[tblsize];
            for(int i=0;i<tblsize;i++)
            pos[i]=0;
    	for(int i=0;i<n;i++){
    		cin>>t; int j,flag=0;
    		for(j=0;j<tblsize;j++)
    		{
    			p=(t%tblsize+j*j)%tblsize;
    			if(pos[p]==0){
    				pos[p]=1;
    				flag=1;
    				break;
    			}
    		}
    		if(!i) flag>0?cout<<p:cout<<"-";
            else flag>0?cout<<" "<<p:cout<<" -";
    	}
    	return 0;
    }
    
  • 相关阅读:
    jsp页面跳转的路径问题
    Hibernate简单的保存操作
    Hibernate中如何完成持久化类和数据库映射文件
    spring中IOC的简单使用
    对称的二叉树 --剑指offer
    二叉树的下一个结点 --剑指offer
    删除链表中重复的结点 --剑指offer
    链表中环的入口结点 --剑指offer
    字符流中第一个不重复的字符 --剑指offer
    表示数值的字符串 --剑指offer
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8159222.html
Copyright © 2011-2022 走看看