zoukankan      html  css  js  c++  java
  • PAT 1078. Hashing

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15

    Sample Output:

    0 1 4 -

    分析

    考察散列,给你一个数,叫你输出该数插到散列表里的位置,如果它不能插入散列表,则输出“-”。还有就是tablesize去大于等于Msize的质数。由题可知,是平方探测。

    #include<iostream>
    #include<math.h> 
    using namespace std;
    int IsPrime(int n){
        if(n <= 1) return 0;
        for(int i=2;i<=sqrt(n);i++)
             if(n%i==0) 
             return 0;   
        return 1;
    }
    int NextPrime(int n){
        while(!IsPrime(n)) n++;
        return n;
    }
    int main(){
    	int msize,n,t;
    	cin>>msize>>n;
    	msize=NextPrime(msize);
    	int pos[msize]={0};
    	for(int i=0;i<n;i++){
    		cin>>t; 
    		int flag=0,p;
    		for(int j=0;j<msize;j++){
    			p=(t%msize+j*j)%msize;
    			if(pos[p]==0){
    			   flag=1;
    			   pos[p]=1;
    			   break;
    			}
    		}
    		if(!i) flag>0?cout<<p:cout<<"-";
            else flag>0?cout<<" "<<p:cout<<" -";
    	}
    	return 0;
    }
    
  • 相关阅读:
    第二阶段站立会议第十天
    第二阶段站立会议第九天
    第二阶段站立会议第八天
    第二阶段站立会议第七天
    第二阶段站立会议第六天
    第二阶段站立会议第五天
    第二阶段站立会议第四天
    第二冲刺阶段个人进度10
    第二冲刺阶段个人进度09
    第二冲刺阶段个人进度08
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8401210.html
Copyright © 2011-2022 走看看