zoukankan      html  css  js  c++  java
  • PAT 1107 Social Clusters

    When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

    Input Specification:
    Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

    K​i : hi [1] hi​​ [2] ... hi [Ki​]

    where Ki​ (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

    Output Specification:
    For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    8
    3: 2 7 10
    1: 4
    2: 5 3
    1: 4
    1: 3
    1: 4
    4: 6 8 1 5
    1: 4

    Sample Output:

    3
    4 3 1

    分析
    参考并查集简析

    #include<iostream> //集合的查并补
    #include<vector>
    #include<algorithm>
    using namespace std;
    vector<int> father, isroot;
    bool cmp(const int& a, const int& b){
      return a>b;
    }
    int findfather(int a){
      int b=a;
      while(father[a]!=a){
        a=father[a];
      }
      while(b != father[b]) {
            int z = b;
            b = father[b];
            father[z] = a;
        }
      return a;
    }
    void Union(int a, int b){ //并集
      int faA= findfather(a);
      int faB= findfather(b);
      if(faA!=faB) father[faA]=faB;
    }
    int main(){
      int N, cnt=0;
      cin>>N;
      vector<int> course(1001, 0);
      father.resize(N+1);
      isroot.resize(N+1);
      for(int i=1; i<=N; i++)
        father[i]=i;
      for(int i=1; i<=N; i++){
        int k;
        scanf("%d:",&k);
        for(int j=0; j<k; j++){
          int t;
          cin>>t;
          if(course[t]==0)
            course[t]=i;
          Union(i, findfather(course[t]));
        }
      }
      for(int i=1; i<=N; i++){
        isroot[findfather(i)]++;
      }
      for(int i=1; i<=N; i++){
        if(isroot[i]!=0)
          cnt++;
      }
      sort(isroot.begin(), isroot.end(), cmp);
      cout<<cnt<<endl;
      for(int i=0; i<cnt; i++)
        i==0?cout<<isroot[i]:cout<<" "<<isroot[i];
      return 0;
    }
    
  • 相关阅读:
    剑指offer_11:二进制中1的个数
    剑指offer_10:矩形覆盖
    spring mvc 访问静态资源
    spring context:component-scan ex
    spring aop配置未生效
    415 Unsupported Media Type
    spring mvc 接收List对象入参
    JIRA甘特图
    JIRA的工时
    JIRA导出工作日志到Excel
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501895.html
Copyright © 2011-2022 走看看