zoukankan      html  css  js  c++  java
  • PAT 1113 Integer Set Partition

    Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1​​ and n​2 numbers, respectively. Let S1​ and S​2 denote the sums of all the numbers in A​1​​ and A​2​​ , respectively. You are supposed to make the partition so that ∣n​1​​ −n​2​​ ∣ is minimized first, and then ∣S​1​​ −S​2​​ ∣ is maximized.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10^5​​ ), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2^​31.

    Output Specification:
    For each case, print in a line two numbers: ∣n​1− n2​ ∣ and ∣S1​​ −S2 ∣, separated by exactly one space.

    Sample Input 1:
    10
    23 8 10 99 46 2333 46 1 666 555

    Sample Output 1:
    0 3611

    Sample Input 2:
    13
    110 79 218 69 3721 100 29 135 2 6 13 5188 85

    Sample Output 2:
    1 9359

    #include<iostream> //水题
    #include<vector>
    #include<algorithm>
    using namespace std;
    bool cmp(const int &a, const int &b){
    	return a>b;
    }
    int main(){
    	int N, sum=0;
    	cin>>N;
    	vector<int> vec(N, 0);
    	for(int i=0; i<N; i++)
    		cin>>vec[i];
    	sort(vec.begin(), vec.end(), cmp);
        int t=N%2==0?N/2:N/2+1;
    	for(int i=0; i<N; i++)
    		if(i<t)
    			sum+=vec[i];
    		else
    			sum-=vec[i];
    	cout<<2*t-N<<" "<<sum<<endl;
    	return 0;
    } 
    
  • 相关阅读:
    hdu 5071
    HDU4945 2048(dp)
    ZOJ3229 Shoot the Bullet(有源汇的上下界最大流)
    HDU Destroy Transportation system(有上下界的可行流)
    Treap模板
    HDU4916 Count on the path(树dp??)
    HDU2829 Lawrence(斜率优化dp)
    HDU3507 Print Article(斜率优化dp)
    POJ3164 Command Network(最小树形图)
    Codeforces 452E Three Strings(后缀自动机)
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9502011.html
Copyright © 2011-2022 走看看