zoukankan      html  css  js  c++  java
  • 二分法的应用:最大化最小值 POJ2456 Aggressive cows

    /*
    二分法的应用:最大化最小值  POJ2456 Aggressive cows
    
    Time Limit: 1000MS        Memory Limit: 65536K
    Total Submissions: 18125        Accepted: 8636
    Description
    
    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).
    
    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
    Input
    
    * Line 1: Two space-separated integers: N and C
    
    * Lines 2..N+1: Line i+1 contains an integer stall location, xi
    Output
    
    * Line 1: One integer: the largest minimum distance
    Sample Input
    
    5 3
    1
    2
    8
    4
    9
    Sample Output
    
    3
    Hint
    
    OUTPUT DETAILS:
    
    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
    
    Huge input data,scanf is recommended.
    Source
    
    USACO 2005 February Gold
     */
    
    import java.util.Arrays;
    import java.util.Scanner;
    
    public class Main {
        static int N, M;
        static int[] a;
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            N = sc.nextInt();
            M = sc.nextInt();
            a = new int[N];
            for (int i = 0; i < N; i++)
                a[i] = sc.nextInt();
            sc.close();
            Arrays.sort(a);
            int low = -1, high = 1000000001;
            while (high - low > 1) {
                int mid = (low + high) / 2;
                if (C(mid)) {
                    low = mid;
                } else {
                    high = mid;
                }
            }
            System.out.println(low);
        }
    
        static boolean C(int X) {
            int last = 0;
            for (int i = 1; i < M; i++) {
                int next = last + 1;
                while (next < N && a[next] - a[last] < X) {
                    next++;
                }
                if (next >= N) return false;
                last = next;
            }
            return true;
        }
    }
  • 相关阅读:
    ffmpeg一些filter使用方法、以及一些功能命令
    Hibernate调试——定位查询源头
    emmet语法
    [心得]传统IT转互联网面试经验分享
    Java中的集合类型的继承关系图
    Java的IO操作中有面向字节(Byte)和面向字符(Character)两种方式
    oracle求时间差的常用函数
    jdbc读取新插入Oracle数据库Sequence值的5种方法
    Xpath语法格式整理
    Oracle中 Instr 这个函数
  • 原文地址:https://www.cnblogs.com/Alpharun/p/8663510.html
Copyright © 2011-2022 走看看