zoukankan      html  css  js  c++  java
  • HDU——1061Rightmost Digit(高次方,找规律)

    Rightmost Digit

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 43847    Accepted Submission(s): 16487


    Problem Description
    Given a positive integer N, you should output the most right digit of N^N.
     


     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single positive integer N(1<=N<=1,000,000,000).
     


     

    Output
    For each test case, you should output the rightmost digit of N^N.
     


     

    Sample Input
    2 3 4
     


     

    Sample Output
    7 6
    Hint
    In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

    水题一道,1、5、0、6结尾的次方均为本身,其余可以看作4次一循环。

    #include<iostream>
    #include<string>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    typedef long long ll;
    ll power(const ll a,const ll n)
    {
        ll sum=1;
        for (int i=1; i<=n; i++)
        {
            sum=sum*a;
        }
        return sum;
    }
    int main(void)
    {
        ll n,t,ans;
        int tt;
        cin>>tt;
        while (tt--)
        {    
            cin>>n;
            t=n%10;
            if(t==1||t==5||t==0||t==6)
            {
                cout<<t<<endl;
                continue;
            }
            else
            {        
                ans=power(t,n%4+4)%10;
                cout<<ans<<endl;
                continue;
            }        
        }
        return 0;
    }
  • 相关阅读:
    bzoj2748:[HAOI2012]音量调节
    bzoj2287:[POJ Challenge]消失之物
    bzoj1485:[HNOI2009]有趣的数列
    Codeforces 620E New Year Tree
    CF813E Army Creation
    527D.Clique Problem
    4337: BJOI2015 树的同构
    Codeforces Round #443 (Div. 1) C. Tournament
    [BZOJ4913][SDOI2017]遗忘的集合
    [八省联考2018]林克卡特树lct
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356443.html
Copyright © 2011-2022 走看看