zoukankan      html  css  js  c++  java
  • PAT 1068 Find More Coins[dp][难]

    1068 Find More Coins (30)(30 分)

    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10^4^ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=10^4^, the total number of coins) and M(<=10^2^, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the face values V~1~ <= V~2~ <= ... <= V~k~ such that V~1~ + V~2~ + ... + V~k~ = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

    Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

    Sample Input 1:

    8 9
    5 9 8 7 2 3 4 1

    Sample Output 1:

    1 3 5

    Sample Input 2:

    4 8
    7 2 4 3

    Sample Output 2:

    No Solution

    //代码来自:https://www.liuchuo.net/archives/2323

    #include <iostream>
    #include <vector>
    #include<stdio.h>
    #include <algorithm>
    using namespace std;
    int dp[10010], w[10010];
    bool choice[10010][110];
    int cmp1(int a, int b){return a > b;}
    int main() {
        int n, m;
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; i++)
            scanf("%d", &w[i]);
        sort(w + 1, w + n + 1, cmp1);
        for(int i = 1; i <= n; i++) {
            for(int j = m; j >= w[i]; j--) {//j的范围表示至少得放下自己。
                if(dp[j] <= dp[j-w[i]] + w[i]) {
                    choice[i][j] = true;
                    printf("%d %d",i,j);
                    dp[j] = dp[j-w[i]] + w[i];
                }
            }
            printf("\n");
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                printf("%d ",choice[i][j]);
            }
            printf("\n");
        }
    
        if(dp[m] != m) printf("No Solution");
        else {
            vector<int> arr;
            int v = m, index = n;
            //由大到小排列,那么从小(n)开始遍历。
            while(v > 0) {
                if(choice[index][v] == true) {
                    arr.push_back(w[index]);
                    v -= w[index];
                }
                index--;
            }
            for(int i = 0; i < arr.size(); i++) {
                if(i != 0) printf(" ");
                printf("%d", arr[i]);
            }
        }
        return 0;
    }

    //这个代码可以说写的超级棒了。

    1.将元素不是从小到大排序,而是从大到小排序。

    2.使用01背包来解决问题,i用来遍历所有的物品,j用来表示数量,并且最小是不超过本物品的重量大小。

    3.choice数组记录物品i在重量为j的情况下是否被选中,并且倒序遍历,好厉害啊。

    给的例子中的choice数组。非常厉害,学习了01数组。

  • 相关阅读:
    java将汉语转换为拼音工具类
    Maven 参数说明
    tcp socket的backlog参数
    Java 运行中jar包冲突,定位使用哪个jar包
    Java CMS GC
    数据仓库
    compareTo
    java程序性能分析之thread dump和heap dump
    npm 与 package.json 快速入门教程
    基本 Java Bean
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9478387.html
Copyright © 2011-2022 走看看