zoukankan      html  css  js  c++  java
  • 【UVa】[1585]Score

    Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

    Description

    Download as PDF

    There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.

    Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

    You are to write a program calculating the scores of test results.

    Input 

    Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ` O' and ` X' and the length of the string is more than 0 and less than 80. There is no spaces between ` O' and ` X'.

    Output 

    Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

    The following shows sample input and output for five test cases.

    Sample Input 

    5 
    OOXXOXXOOO 
    OOXXOOXXOO 
    OXOXOXOXOXOXOX 
    OOOOOOOOOO 
    OOOOXOOOOXOOOOX
    

    Sample Output 

    10 
    9 
    7 
    55 
    30
    

    这个粘贴出来的效果挺漂亮的啊……


    用i统计连续O的个数,遇见X则i清零


    scanf版:

    #include<stdio.h>
    #include<string.h>
    int main() {
    	int n,sum,l,t;
    	char s[100];
    	scanf("%d",&n);
    	while(n--) {
    		scanf("%s",s);
    		l=strlen(s);
    		for(int i=t=sum=0; i<l; i++) {
    			if(s[i]=='X')
    				t=0;
    			else if(s[i]=='O') {
    				sum+=++t;
    			}
    		}
    		printf("%d\n",sum);
    	}
    	return 0;
    }


    getchar版:


    #include<stdio.h>
    int main() {
    	int n,sum,i;
    	char t;
    	scanf("%d\n",&n);
    	while(n--) {
    		i=sum=0;
    		while(t=getchar(),t!='\n') {
    			if(t=='X')
    				i=0;
    			else if(t=='O') {
    				sum+=++i;
    			}
    		}
    		printf("%d\n",sum);
    	}
    	return 0;
    }

    话说第一次写的时候不知道为什么写不对

    然后今天突然迷之直接写出来了


    题目地址:【UVa】[1585]Score

  • 相关阅读:
    11111
    JavaScript基础
    CSS使用
    CSS 基本
    前端之HTML
    Python 迭代器和生成器
    Python day11
    Python 函数
    第十七篇:django基础(二)
    第十六篇:django基础
  • 原文地址:https://www.cnblogs.com/BoilTask/p/12569935.html
Copyright © 2011-2022 走看看