zoukankan      html  css  js  c++  java
  • POJ 1836 Alignment



    Alignment
    Time Limit: 1000MSMemory Limit: 30000K
    Total Submissions: 11450Accepted: 3647

    Description

    In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

    Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

    Input

    On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

    There are some restrictions: 
    2 <= n <= 1000 
    the height are floating numbers from the interval [0.5, 2.5] 

    Output

    The only line of output will contain the number of the soldiers who have to get out of the line.

    Sample Input

    8
    1.86 1.86 1.30621 2 1.4 1 1.97 2.2

    Sample Output

    4

    Source

    Romania OI 2002 

    DP两遍LIS,
    a1<a2<a3<.....<ai<=>ai+1>ai+2>ai+3>....a+n

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    int getLIS(int* a,int len)
    {
        int dp[1100],cnt=1;
        dp[0]=a[0];
        for(int i=1;i<len;i++)
        {
            if(dp[cnt-1]<a)
            {
                dp[cnt++]=a;
            }
            else
            {
                *lower_bound(dp,dp+cnt,a)=a;
            }
        }
        return cnt;
    }

    int main()
    {
        int n;
        int a[1100],b[1100],c[1100],ans=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            double x;
            scanf("%lf",&x);
            a=x*100000;
        }
        for(int i=0;i<n-1;i++)
        {
            for(int j=0;j<=i;j++)
                b[j]=a[j];
            for(int j=n-1;j>i;j--)
                c[n-1-j]=a[j];
            ans=max(getLIS(b,i+1)+getLIS(c,n-i-1),ans);
        }
        printf("%d ",n-ans);
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    Hive学习小记-(4)带复杂集合类型及指定多分隔符hive建表
    nowcoder-shell篇(grep、awk、sed为主)
    剑指offer02-替换空格
    剑指offer67-剪绳子**
    爬虫5-Scrapy爬虫架构
    爬虫4-网站结构分析
    爬虫3-python爬取非结构化数据下载到本地
    项目创建
    项目框架搭建
    项目表结构
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350854.html
Copyright © 2011-2022 走看看