zoukankan      html  css  js  c++  java
  • POJ 3020 Antenna Placement



    Antenna Placement
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 5645Accepted: 2825

    Description

    The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
    POJ 3020 Antenna Placement - qhn999 - 码代码的猿猿 
    Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

    Input

    On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

    Output

    For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

    Sample Input

    2
    7 9
    ooo**oooo
    **oo*ooo*
    o*oo**o**
    ooooooooo
    *******oo
    o*o*oo*oo
    *******oo
    10 1
    *
    *
    *
    o
    *
    *
    *
    *
    *
    *

    Sample Output

    17
    5

    Source

    Svenskt M?sterskap i Programmering/Norgesmesterskapet 2001 



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>

    using namespace std;

    const int MaxV=500;
    char mp[50][50];
    int dir_x[4]={0,0,1,-1};
    int dir_y[4]={1,-1,0,0};
    int h,w;

    bool inmap(int x,int y)
    {
        if(x>=0&&x<h&&y>=0&&y<w)
            return true;
        return false;
    }

    struct Edge
    {
        int to,next;
    }E[MaxV*MaxV];

    int Adj[MaxV],Size;

    void Init()
    {
        Size=0;
        memset(Adj,-1,sizeof(Adj));
    }

    void Add_Edge(int u,int v)
    {
        E[Size].to=v;
        E[Size].next=Adj;
        Adj=Size++;
    }
    bool use[MaxV*MaxV];
    int from[MaxV*MaxV];

    bool match(int u)
    {
        for(int i=Adj;~i;i=E.next)
        {
            int v=E.to;
            if(!use[v])
            {
                use[v]=true;
                if(from[v]==-1||match(from[v]))
                {
                    from[v]=u;
                    return true;
                }
            }
        }
        return false;
    }

    int main()
    {
        int T;
        cin>>T;
        while(T--)
        {
            cin>>h>>w;
            Init();  vector<int> v;
            for(int i=0;i<h;i++)
            {
                cin>>mp;
            }
            for(int i=0;i<h;i++)
            {
                for(int j=0;j<w;j++)
                {
                    if(mp[j]=='*')
                    {
                        v.push_back(i*w+j);
                        for(int k=0;k<4;k++)
                        {
                            int x=i+dir_x[k];
                            int y=j+dir_y[k];
                            if(inmap(x,y)&&mp[x][y]=='*')
                            {
                             //   printf("(%d,%d)----->(%d,%d) ",i,j,x,y);
                                Add_Edge(i*w+j,x*w+y);
                            }
                        }
                    }
                }
            }
            int tot=0;
            memset(from,-1,sizeof(from));
            for(int i=0;i<v.size();i++)
            {
                int u=v;
                memset(use,false,sizeof(use));
                if(match(u)) tot++;
            }
            printf("%d ",v.size()-tot/2);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    第一章 Java入门
    2020-2021-2 网络对抗技术 20181321 Exp 8 Web基础
    2020-2021-2 网络对抗技术 20181321 Exp7 网络欺诈防范
    2020-2021-2 网络对抗技术 20181321 Exp6 MSF基础应用
    Weblogic漏洞复现:CVE-2020-14882未授权代码执行
    利用cse-2020-16127,cve-2020-16125进行漏洞再现
    实验一-密码引擎-加密API实现与测试
    实验一-密码引擎-加密API研究
    API标准
    020-2021-2 网络对抗技术 20181321 Exp5 信息搜集与漏洞扫描
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350871.html
Copyright © 2011-2022 走看看