zoukankan      html  css  js  c++  java
  • HDOJ 1698 Just a Hook

    http://acm.hdu.edu.cn/showproblem.php?pid=1698
    线段树。。。。成段更新。。。。。。。。

    Just a Hook

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 12958    Accepted Submission(s): 6448


    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

    HDOJ 1698 Just a Hook - qhn999 - 码代码的猿猿


    Now Pudge wants to do some operations on the hook.

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

    For each cupreous stick, the value is 1.
    For each silver stick, the value is 2.
    For each golden stick, the value is 3.

    Pudge wants to know the total value of the hook after performing the operations.
    You may consider the original hook is made up of cupreous sticks.
     

    Input
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     

    Output
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     

    Sample Input
    1
    10
    2
    1 5 2
    5 9 3
     

    Sample Output
    Case 1: The total value of the hook is 24.
     

    Source
     

    Recommend
    wangye
      



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1

    const int MAXN=1111111;

    int sum[MAXN<<2],add[MAXN<<2];

    void pushUP(int rt)
    {
        sum[rt]=sum[rt<<1]+sum[rt<<1|1];
    }

    void pushDOWN(int rt,int m)
    {
        if(add[rt])
        {
            add[rt<<1]=add[rt<<1|1]=add[rt];
            sum[rt<<1]=add[rt]*(m-(m>>1));
            sum[rt<<1|1]=add[rt]*(m>>1);
            add[rt]=0;
        }
    }

    void build(int l,int r,int rt)
    {
        add[rt]=0;
        sum[rt]=1;
        if(l==r) return ;
        int m=(r+l)>>1;
        build(lson); build(rson);
        pushUP(rt);
    }

    void update(int L,int R,int c,int l,int r,int rt)
    {
        if(L<=l&&r<=R)
        {
            add[rt]=c;
            sum[rt]=add[rt]*(r-l+1);
            return ;
        }
        pushDOWN(rt,r-l+1);
        int m=(l+r)>>1;
        if(L<=m) update(L,R,c,lson);
        if(R>m) update(L,R,c,rson);

        pushUP(rt);
    }

    int main()
    {
        int T,cas=1;
        scanf("%d",&T);
    while(T--)
    {
        int n,m,a,b,c;
        scanf("%d",&n);
        build(1,n,1);
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d. ",cas++,sum[1]);
    }

        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Autumn )

  • 相关阅读:
    CLOSE_WAIT过大,致使tomcat停掉
    nginx安装
    前端知识点及面试题总结
    博客第一次
    二叉树的深度-python
    数字在排序数组中出现的次数-python
    两个链表的第一个公共节点-python
    自动生成接口自动化测试报告
    python实现四舍五入
    使用python的configparser操作.ini配置文件
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350910.html
Copyright © 2011-2022 走看看