zoukankan      html  css  js  c++  java
  • HDOJ 3555 Bomb (数位DP)



    Bomb

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
    Total Submission(s): 3935    Accepted Submission(s): 1369


    Problem Description
    The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
    Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
     

    Input
    The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

    The input terminates by end of file marker.
     

    Output
    For each test case, output an integer indicating the final points of the power.
     

    Sample Input
    3
    1
    50
    500
     

    Sample Output
    0
    1
    15
    Hint
    From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",so the answer is 15.
     

    Author
    fatboy_cw@WHU
     

    Source
     

    Recommend
    zhouzeyong
     


    #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    unsigned long long int dp[30][3];

    void init()
    {
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<30;i++)
        {
            dp[0]=dp[i-1][0]*10-dp[i-1][1];                                 //不包含49的
            dp[1]=dp[i-1][0];                                                      //不包含49的但是开通为9的
            dp[2]=dp[i-1][2]*10+dp[i-1][1];                                 //包含49的
        }
    }

    int main()
    {
        int T;
        unsigned long long int n;
        init();
        scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d",&n);
        unsigned long long int ans=0;
        int dist[30];
        memset(dist,0,sizeof(dist));

        n++;
        int len=0;
        while(n)
        {
            dist[++len]=n%10;
            n/=10;
        }

        bool is49=false;
        int last=0;
        for(int i=len+1;i>=1;i--)
        {
            ans+=dist*dp[i-1][2];
            if(is49)
            {
                ans+=dp[i-1][0]*dist;
            }

            if(!is49&&dist>4)
            {
                ans+=dp[i-1][1];
            }

            if(last==4&&dist==9)
                is49=true;

            last=dist;
        }

        printf("%I64d ",ans);
    }

        return 0;
    }


  • 相关阅读:
    GoLang设计模式04
    GoLang设计模式03
    GoLang设计模式02
    GoLang设计模式01
    封装python代码,避免被轻易反编译
    openEuler 欧拉安装图形界面
    Deepin
    Debian安装PostgreSQL
    在 Linux 上使用 VirtualBox 的命令行管理界面
    Debian无法通过ssh连接
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350967.html
Copyright © 2011-2022 走看看