zoukankan      html  css  js  c++  java
  • UVA 10003





      Cutting Sticks 

    You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

    It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

    Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

    Input 

    The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made.

    The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.

    An input case with l = 0 will represent the end of the input.

    Output 

    You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

    Sample Input 

    100
    3
    25 50 75
    10
    4
    4 5 7 80

    Sample Output 

    The minimum cutting is 200.
    The minimum cutting is 22.



    Miguel Revilla 
    2000-08-21




    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>

    using namespace std;
    const int INF=0x3f3f3f3f;

    int dp[1010][1010];

    int n,len;
    int a[50];

    int d(int head,int tail)
    {
        int& ans=dp[head][tail];
        if(ans!=INF) return ans;
        for(int i=1;i<=n;i++)
        {
            if(a>head&&a<tail)
            {
                ans=min(ans,d(head,a)+d(a,tail)+(tail-head));
            }
        }
        return ans;
    }

    int main()
    {
    while(scanf("%d",&len)!=EOF&&len)
    {
        scanf("%d",&n);

        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
        }
        a[0]=0;
        a[n+1]=len;

        for(int i=0;i<=len;i++)
        {
            for(int j=0;j<=len;j++)
            {
                dp[j]=INF;
            }
        }

        for(int i=1;i<=n+1;i++)
        {
            dp[a[i-1]][a]=0;
        }

        d(0,len);

        printf("The minimum cutting is %d. ",dp[0][len]);
    }

        return 0;
    }



  • 相关阅读:
    心慌慌
    辛苦了
    [转]家庭长寿秘方:夫妻关系之守则。
    无题
    浮躁
    [转]樱木花道9大缺点
    一票难求
    Excel录入数据,自动记录当前时间点
    Excel数据透视表基本使用
    linux下tomcat7虚拟目录配置
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350970.html
Copyright © 2011-2022 走看看