zoukankan      html  css  js  c++  java
  • POJ 1163 The Triangle

    The Triangle
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 32637Accepted: 19322

    Description

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    Output

    Your program is to write to standard output. The highest sum is written as an integer.

    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Source

    IOI 1994

    #include <iostream>
    #include <cstring>

    using namespace std;

    int a[111][111];
    int dp[111][111];

    int main()
    {
        int n;
        cin>>n;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=i;j++)
               cin>>a[j];
        memset(dp,0,sizeof(dp));

        for(int i=1;i<=n;i++)
            dp[n]=a[n];

        for(int i=n-1;i>=1;i--)
            for(int j=1;j<=i;j++)
               dp[j]=max(dp[i+1][j],dp[i+1][j+1])+a[j];

        cout<<dp[1][1]<<endl;

        return 0;
    }

  • 相关阅读:
    Maxwell的vbs脚本转matlab
    maxwell电机直观理解
    maxwell电机转矩扫描与使用MTPA策略绘制效率map图
    maxwell施加均匀外磁场
    maxwell的那些坑&小技巧
    maxwell主从边界
    MySql基础
    数据结构知识结构框架图
    第八章 多线程
    软件
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351058.html
Copyright © 2011-2022 走看看