zoukankan      html  css  js  c++  java
  • HDOJ 2955 Robberies

    类似01背包的DP

    Robberies

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 7013    Accepted Submission(s): 2630


    Problem Description
    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

    HDOJ 2955 Robberies - qhn999 - 码代码的猿猿

    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     

    Input
    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     

    Output
    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

    Notes and Constraints
    0 < T <= 100
    0.0 <= P <= 1.0
    0 < N <= 100
    0 < Mj <= 100
    0.0 <= Pj <= 1.0
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     

    Sample Input
    3
    0.04 3
    1 0.02
    2 0.03
    3 0.05
    0.06 3
    2 0.03
    2 0.03
    3 0.05
    0.10 3
    1 0.03
    2 0.02
    3 0.05
     

    Sample Output
    2
    4
    6
     
    #include <iostream>
    #include <cstring>

    using namespace std;

    double f[100000];

    int main()
    {
        int T;
        cin>>T;
    while(T--)
    {
        int sum=0;
        int m[101];
        double sur[101];
        memset(f,0,sizeof(f));
        f[0]=1;
        int N; double P;
        cin>>P>>N;
        for(int i=0;i<N;i++)
        {
            double k;
            cin>>m>>k;
            sur=1-k;
            sum+=m;
        }

        for(int i=0;i<N;i++)
        {
            for(int j=sum;j>=m;j--)
                f[j]=max(f[j],f[j-m]*sur);
        }

        P=1-P;
        for(int j=sum;j>=0;j--)
            if(f[j]>=P)
            {
                cout<<j<<endl;
                break;
            }
    }
        return 0;
    }



  • 相关阅读:
    JS---案例:tab切换效果
    .net core 使用MD5加密解密字符串
    c#实战开发:用.net core开发一个简单的Web以太坊钱包 (六)
    c#实战开发:以太坊Geth 命令发布智能合约 (五)
    c#实战开发:以太坊Geth 常用命令 (四)
    c#实战开发:以太坊钱包快速同步区块和钱包卡死解决方案 (三)
    c#实战开发:以太坊钱包对接私链 (二)
    c# API接受图片文件以文件格式上传图片
    c# API接受图片文件以Base64格式上传图片
    命令查看当前电脑安装所有版本.NET Core SKD
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351061.html
Copyright © 2011-2022 走看看