zoukankan      html  css  js  c++  java
  • Find a way HDU

    Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
    Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
    Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

    InputThe input contains multiple test cases. 
    Each test case include, first two integers n, m. (2<=n,m<=200). 
    Next n lines, each line included m character. 
    ‘Y’ express yifenfei initial position. 
    ‘M’    express Merceki initial position. 
    ‘#’ forbid road; 
    ‘.’ Road. 
    ‘@’ KCF 
    OutputFor each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.Sample Input

    4 4
    Y.#@
    ....
    .#..
    @..M
    4 4
    Y.#@
    ....
    .#..
    @#.M
    5 5
    Y..@.
    .#...
    .#...
    @..M.
    #...#

    Sample Output

    66
    88
    66
    #include<iostream>
    #include<sstream>
    #include<algorithm>
    #include<cstdio>
    #include<string.h>
    #include<string>
    #include<cmath>
    #include<cmath>
    #include<vector>
    #include<stack>
    #include<queue>
    #include<map>
    #include<set>
    using namespace std;
    const int INF=204;
    const int M=0x1f1f1f1f;
    int n,m,z;
    char cnt[INF][INF];
    int dir[][2]={{1,0},{0,-1},{-1,0},{0,1}};
    int dis[INF][INF][2];
    int vis[INF][INF];
    struct Node{
        int x,y,step;
        Node(int x,int y,int z):x(x),y(y),step(z){}
        Node(){}
    };
    void bfs(int x,int y){
        memset(vis,0,sizeof(vis));
        vis[x][y]=1;
        queue<Node>q;
        q.push(Node(x,y,0));
        while(!q.empty()){
            Node u=q.front();
            q.pop();
            for(int i=0;i<4;i++){
                int tx=u.x+dir[i][0];
                int ty=u.y+dir[i][1];
                if(!vis[tx][ty]&&tx>=1&&tx<=n&&ty>=1&&ty<=m&&cnt[tx][ty]!='#'){
                    vis[tx][ty]=1;
                    dis[tx][ty][z]=u.step+1;
                    q.push(Node(tx,ty,u.step+1));
                }
            }
        }
    }
    int main(){
        while(cin>>n>>m){
            for(int i=0;i<2;i++){
                for(int j=1;j<=n;j++){
                    for(int k=1;k<=m;k++)
                    dis[j][k][i]=M;
                }
            }
            for(int i=1;i<=n;i++)
            scanf("%s",cnt[i]+1);
            for(int i=1;i<=n;++i)
            for(int j=1;j<=m;j++){
                if(cnt[i][j]=='Y'){
                    z=1;
                    bfs(i,j);
                }
                if(cnt[i][j]=='M'){
                    z=0;
                    bfs(i,j);
                }
            }
            int ans=M;
            for(int i=1;i<=n;i++){
                for(int j=1;j<=m;j++){
                    if(cnt[i][j]=='@'){
                        //去同一家KFC的距离之和 
                        ans=min(ans,dis[i][j][0]+dis[i][j][1]);
                    }
                }
            }
            cout<<ans*11<<endl;
        }
    }
  • 相关阅读:
    win10 访问共享缺少 SMB1协议
    H3C 设置用户和密码
    vim 注释和删除多行
    工商银行贵金属网址
    Team Foundation Server 2008 安装 全程记录
    临时表和表变量 区别
    Windows Server 2003开机自动登录
    索引工作原理
    WebService是什么
    CodeFirst
  • 原文地址:https://www.cnblogs.com/CuteAbacus/p/9492221.html
Copyright © 2011-2022 走看看