zoukankan      html  css  js  c++  java
  • poj2367 tupo_sort裸题

    Genealogical tree
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 4309   Accepted: 2866   Special Judge

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1

    裸体模板直接过,wa了一次,要裸奔了...
    比较有意思的是,复习了tupu_sort的模板,初始阶段计算所有节点的入度,遍历所有节点,入度为0的弹入栈,更新其余节点的入度,重复以上操作
    本题是必然存在一个tupu_sort,所以我们每次将一个入度为0的弹入栈就好了,所以注意break,(可以把当前的indegree[i]更新为-1,这样就可以去掉vist了,下次就不会找到此节点)
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cmath>
    #include <string>
    #include <stack>
    #include <queue>
    #include <algorithm>
    
    const int inf = 0x3f3f3f;
    const int MAXN = 1e2+10;
    //const int MMAXN = 2e5+10;
    using namespace std;
    
    int n;
    int G[MAXN][MAXN];
    int indegree[MAXN];
    int vist[MAXN];
    int ways[MAXN];
    
    int main()
    {
        int t;
        while(scanf("%d",&n)!=EOF){
            memset(G,0,sizeof(G));
            memset(indegree,0,sizeof(indegree));
            memset(vist,0,sizeof(vist));
            int top=0;
            for(int i=1;i<=n;i++){
                while(scanf("%d",&t),t){
                    G[i][t] = 1;
                    indegree[t]++;
                }
            }
            for(int i=1;i<=n;i++){
                for(int j=1;j<=n;j++){
                    if(!vist[j]&&indegree[j]==0){
                        ways[top++] = j;
                        vist[j] = 1;
                        /*for(int k=1;k<=n;k++){
                            if(G[j][k]==1)
                                indegree[k]--;
                        }*/
                        break;
                    }
                    
                }
                for(int j=1;j<=n;j++){
                    if(G[ways[top-1]][j]){
                        indegree[j]--;
                    }
                }
            }
            for(int i=0;i<top-1;i++)
                cout<<ways[i]<<" ";
            cout<<ways[top-1]<<endl;
        }
       // cout << "Hello world!" << endl;
        return 0;
    }
    View Code
    在一个谎言的国度,沉默就是英雄
  • 相关阅读:
    如何卸载Mysql
    netty4.1.32 pipeline的添加顺序和执行顺序
    protobuf 在win10系统如何编译jar包
    java swing 的各种布局layout
    一些大神的代码功底方面的文章
    图解ByteBuffer
    Eclipse 高亮显示选中的相同变量
    Java synchronized详解(java 线程同步)
    一篇非常全面的 《单例模式》 的讲解的文章
    java中ThreadLocalRandom类和Random类的使用
  • 原文地址:https://www.cnblogs.com/EdsonLin/p/5444897.html
Copyright © 2011-2022 走看看