zoukankan      html  css  js  c++  java
  • POJ 1200:Crazy Search(哈希)

                                              Crazy Search

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 32483   Accepted: 8947

    Description

    Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
    Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

    As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

    Input

    The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

    Output

    The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

    Sample Input

    3 4
    daababac

    Sample Output

    5

    题意

    给出一个字符串,将字符串分成长度为n的子串(连续的)。问这些子串中有多少不同的子串

    思路

    记录每个子串的哈希值,存在数组里,去重后输出数组的长度即可

    AC代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ull unsigned long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x7f7f7f7f
    const double E=exp(1);
    const int maxn=1e6+10;
    const int mod=1e9+7;
    const int base=1007;
    using namespace std;
    ull a[maxn];
    ull b[maxn];
    char ch[maxn];
    char c[maxn];
    // 计算哈希值
    ull get_hash(char ch[],int k,int l)
    {
    	ull ans=0;
    	for(int i=k;i<=k+l-1;i++)
    	{
    		ans=(ans*base+ch[i])%mod;
    	}
    	return ans;
    }
    int main(int argc, char const *argv[])
    {
    	ios::sync_with_stdio(false);
    	int n,m;
    	cin>>n>>m;
    	cin>>ch;
    	int l=strlen(ch);
    	for(int i=1;i<=l;i++)
    		c[i]=ch[i-1];
    	int k=0;
    	for(int i=1;i<=l-n+1;i++)
    	{
    		b[k++]=get_hash(c,i,n);
    	}
    	sort(b,b+k);
    	// 去重
    	k=unique(b,b+k)-b;
    	cout<<k<<endl;
    	return 0;
    }
  • 相关阅读:
    【集合】元组元素命名
    普通数组-队列
    稀疏数组
    Java基础 07 API概述 Scanner类 Random类 ArrayList类
    Java基础 06 类与对象、封装、构造方法
    Java基础 05 数组
    Java基础 04 IDEA、方法
    Java基础 04 [附] IDEA 的安装、配置与使用
    Java基础 03 流程控制语句
    Java基础 02 数据类型转换、运算符、方法入门
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324390.html
Copyright © 2011-2022 走看看