zoukankan      html  css  js  c++  java
  • 超级楼梯 递推动规

                                                           超级楼梯

    Description

    有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?
     

    Input

    输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。
     

    Output

    对于每个测试实例,请输出不同走法的数量
     

    Sample Input

    2 2 3
     

    Sample Output

    1 2
     

    #include<iostream>
    using namespace std;
    int a[44];
    int main(){
        a[1] = 0, a[2] = 1, a[3] = 2;
        for(int i=4; i<=40; i++)
            a[i] = a[i-1] + a[i-2];
        int n;
        cin>>n;
        while(n--){
            int m;
            cin>>m;
            cout<<a[m]<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    hinge loss
    KL散度
    pygame 学习
    pytorch 反向传播
    在线画数学函数图
    recover deleted files
    98个关键点的人脸
    Pytorch详解BCELoss和BCEWithLogitsLoss
    one hot vector
    Effective C++
  • 原文地址:https://www.cnblogs.com/Genesis2018/p/8304803.html
Copyright © 2011-2022 走看看