zoukankan      html  css  js  c++  java
  • Milk 结构体

                                                                                                     Milk

    Description

    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:
    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200 ml milk everyday.
    3. If the milk left in the bottle is less than 200 ml, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volume of a bottle is smaller than 200 ml, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
     

    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(ml) which is the volume of a bottle.
     

    Output

    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
     

    Sample Input

    2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
     

    Sample Output

    Mengniu Mengniu

    Hint

    In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case,
    milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest. 
     

    <pre name="code" class="cpp">#include<iostream>
    using namespace std;
    struct milk{
      int vol, price;
      double cost;
      char brand[101];
    }a[100], b;
    int main(){
      int t;
      cin>>t;
      while(t--){
      int n, i, p=0;
      cin>>n;
      for(i=0; i<n; i++){
         cin>>b.brand>>b.price>>b.vol;
         if(b.vol < 200)  continue;
         else {
             a[p] = b;
             if(a[p].vol >= 1000) a[p].cost = a[p].price*1.0/5;
             else {
               a[p].cost = a[p].price*1.0 / (a[p].vol/200);
             }
         p++;
         }
      }
      for(i=0; i<p; i++)
        for(int j=p-1; j>i; j--)
            if(a[j-1].cost > a[j].cost || (a[j-1].cost==a[j].cost && a[j].vol>a[j-1].vol)){
                struct milk tmp;
                tmp = a[j];
                a[j] = a[j-1];
                a[j-1] = tmp;
            }
        cout<<a[0].brand<<endl;
      }
    return 0;
    }


    
    

  • 相关阅读:
    鼠标的移动触发函数改变字体颜色
    Godaddy创始人:成就亿万富翁的10条规则
    关于编程,大学没有传授的十件事
    Using XAMPP for Local WordPress Theme Development
    100+ Resources for Web Developer
    你必须非常努力,才能看起来毫不费力
    建立WordPress博客网站——个人教程
    函数指针和指针函数
    每天写出好代码的5个建议
    LumiSoft Mail Server
  • 原文地址:https://www.cnblogs.com/Genesis2018/p/8304838.html
Copyright © 2011-2022 走看看