zoukankan      html  css  js  c++  java
  • POJ 1797 Heavy Transportation SPFA变形

    原题链接:http://poj.org/problem?id=1797

    Heavy Transportation
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 24576   Accepted: 6510

    Description

    Background 
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

    Problem 
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input

    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

    Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5
    

    Sample Output

    Scenario #1:
    4
    

    Source

    TUD Programming Contest 2004, Darmstadt, Germany

    题意

    对于一条路径的限制大小,定义为这条路径上最短的那条边。给你一个无向图,问你从1出发到n的所有路径中,限制大小最大是多少。

    题解

    定义dp[i]表示从1走到 i 时的限制大小的最大值。然后就像spfa那样,每次从队列里面拿点出来松弛,如果松弛成功,则入队。

    代码

    #include<iostream>
    #include<queue>
    #include<cstring>
    #include<algorithm>
    #include<vector>
    #include<cstdio>
    #define INF 1000006
    #define MAX_N 1003
    using namespace std;
    
    int d[MAX_N];
    int T;
    
    struct node {
    public:
        int u, c;
    
        node(int uu, int cc) : u(uu), c(cc) { }
    
        node() { }
    };
    
    struct edge {
    public:
        int to, cost;
    
        edge(int t, int c) : to(t), cost(c) { }
    
        edge() { }
    };
    
    queue<node> que;
    vector<edge> G[MAX_N];
    void spfa(int s) {
        que.push(node(s, INF));
        d[s] = INF;
        while (que.size()) {
            node now = que.front();
            que.pop();
            if (now.c != d[now.u])continue;
            int u = now.u;
            for (int i = 0; i < G[u].size(); i++) {
                int v = G[u][i].to;
                int t = min(d[u], G[u][i].cost);
                if (t > d[v]) {
                    d[v] = t;
                    que.push(node(v, t));
                }
            }
        }
    }
    int n,m;
    
    int main() {
        scanf("%d", &T);
        int cas = 0;
        while (T--) {
            scanf("%d%d", &n, &m);
            for (int i = 0; i <= n; i++)G[i].clear();
            while (que.size())que.pop();
            memset(d, 0, sizeof(d));
            for (int i = 0; i < m; i++) {
                int u, v, c;
                scanf("%d%d%d", &u, &v, &c);
                G[u].push_back(edge(v, c));
                G[v].push_back(edge(u, c));
            }
            spfa(1);
            printf("Scenario #%d:
    %d
    
    ", ++cas, d[n]);
        }
        return 0;
    }
  • 相关阅读:
    等级,
    JS高阶---回调函数
    JS高阶---函数
    JS高阶---对象
    JS高阶---数据、变量、内存
    JS高阶---简介+数据类型
    JS里==和===区别
    vue中assets和static的区别
    vue2.0 实现导航守卫(路由守卫)---登录验证
    exports与module.exports,export与export default 之间的关系和区别
  • 原文地址:https://www.cnblogs.com/HarryGuo2012/p/4746318.html
Copyright © 2011-2022 走看看