zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1077 Kuchiguse (20分) (string反转)

    1.题目

    The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

    • Itai nyan~ (It hurts, nyan~)

    • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

    Sample Input 1:

    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    

    Sample Output 1:

    nyan~
    

    Sample Input 2:

    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    

    Sample Output 2:

    nai

    2.题目分析

    因为长度不一样,所以反转后进行比较

    3.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int main()
    {
    	int n;
    	scanf("%d", &n);
    	string temp;
    	string out = "";
    	getchar();
    	getline(cin, temp);
    	out = temp;
    	reverse(out.begin(), out.end());
    
    	for (int i = 1; i < n; i++)
    	{
    		getline(cin, temp);
    		reverse(temp.begin(), temp.end());
    		int l = min(out.length(), temp.length());
    		int j;
    		for (int j = 0; j < l; j++)
    		{
    			if (out[j] != temp[j]) { out = out.substr(0, j); break; }
    		}
    	}
    	reverse(out.begin(), out.end());
    	if (out.length()>0)
    		cout << out;
    	else cout << "nai";
    }
  • 相关阅读:
    软件质量保证(SQA)
    软件质量保证(SQA)
    在应用程序中使用 Ajax 的时机
    3月18日工作日志88250
    Eclipse 4.0计划
    3月15日工作日志88250
    Eclipse 4.0计划
    3月18日工作日志88250
    在应用程序中使用 Ajax 的时机
    3月15日工作日志88250
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788826.html
Copyright © 2011-2022 走看看