zoukankan      html  css  js  c++  java
  • Problem C: 从点到面

     

    Problem C: 从点到面

    Time Limit: 1 Sec  Memory Limit: 128 MB
    Submit: 3317  Solved: 1854
    [Submit][Status][Web Board]

    Description

    一个矩形可以由左上角和右下角的顶点而唯一确定。现在请定义两个类:Point和Rectangle。

    其中Point类有x和y两个属性(均为int类型),表示二维空间内一个点的横纵坐标,并具有相应的构造函数、析构函数和拷贝构造函数。此外,还有getX()和getY()方法用以得到一个点的坐标值。

    Rectangle类有leftTop和rightBottom两个属性(均为Point类的对象),表示一个矩形的左上角和右下角的两个点,并具有相应的构造函数、析构函数。此外,还有getLeftTop()、getRightBottom()方法用于获取相应的左上角点、右下角点,getArea()方法用以获取面积。

    Input

    输入有多行。

    第一行是一个正整数M,表示后面有M个测试用例。

    每个测试用例占一行,包括4个正整数,分别为左上角的横坐标、纵坐标,右下角的横坐标、纵坐标。

    注意:

    1.请根据输出样例判断两个类中相应方法的书写方法。

    2. 假定屏幕的左下角为坐标原点。

    Output

    输出见样例。

    Sample Input

    1
    10 10 20 0
    

      

    Sample Output

    A point (10, 10) is created!
    A point (20, 0) is created!
    A rectangle (10, 10) to (20, 0) is created!
    Area: 100
    Left top is (10, 10)
    A point (20, 0) is copied!
    A point (20, 0) is copied!
    Right bottom is (20, 0)
    A point (20, 0) is erased!
    A point (20, 0) is erased!
    A rectangle (10, 10) to (20, 0) is erased!
    A point (20, 0) is erased!
    A point (10, 10) is erased!
    

      

    HINT

     

    Append Code

    append.cc
    int main()
    {
        int cases;
        int x1, y1, x2, y2;
    
        cin>>cases;
        for (int i = 0; i < cases; i++)
        {
            cin>>x1>>y1>>x2>>y2;
            Rectangle rect(x1,y1,x2,y2);
            cout<<"Area: "<<rect.getArea()<<endl;
            cout<<"Left top is ("<<rect.getLeftTop().getX()<<", "<<rect.getLeftTop().getY()<<")"<<endl;
            cout<<"Right bottom is ("<<rect.getRightBottome().getX()<<", "<<rect.getRightBottome().getY()<<")"<<endl;
        }
        return 0;
    }
    

      

    #include <iostream>
    using namespace std;
    class Point
    {
    public :
        double x_, y_;
        Point(double x=0):x_(x), y_(x)
        {
            cout<<"A point ("<<x_<<", "<<y_<<") is created!"<<endl;
        }
        Point(double x, double y):x_(x), y_(y)
        {
            cout<<"A point ("<<x_<<", "<<y_<<") is created!"<<endl;
        }
        Point(const Point &p)
        {
            x_=p.x_; y_=p.y_;
            cout<<"A point ("<<x_<<", "<<y_<<") is copied!"<<endl;
        }
        double getX(){return x_;}
        double getY(){return y_;}
        ~Point()
        {
            cout<<"A point ("<<x_<<", "<<y_<<") is erased!"<<endl;
        }
    };
    class Rectangle
    {
    public :
        Point leftTop, rightBottom;
        double x1, y1, x2, y2;
        Rectangle(double a, double b, double c, double d):leftTop(a,b), rightBottom(c,d)
        {
            x1=a; y1=b; x2=c; y2=d;
            cout<<"A rectangle ("<<a<<", "<<b<<") to ("<<c<<", "<<d<<") is created!"<<endl;
        }
        Point &getLeftTop()
        {
            return leftTop;
        }
        Point getRightBottome()//本题纯属胡闹,为了一个出现copy一个不出现copy一个加&一个不加&。
        {
            return rightBottom;
        }
        double getArea()
        {
            return(x1-x2)*(y2-y1);
        }
        ~Rectangle()
        {
             cout<<"A rectangle ("<<x1<<", "<<y1<<") to ("<<x2<<", "<<y2<<") is erased!"<<endl;
        }
    
    };
    int main()
    {
        int cases;
        int x1, y1, x2, y2;
    
        cin>>cases;
        for (int i = 0; i < cases; i++)
        {
            cin>>x1>>y1>>x2>>y2;
            Rectangle rect(x1,y1,x2,y2);
            cout<<"Area: "<<rect.getArea()<<endl;
            cout<<"Left top is ("<<rect.getLeftTop().getX()<<", "<<rect.getLeftTop().getY()<<")"<<endl;
            cout<<"Right bottom is ("<<rect.getRightBottome().getX()<<", "<<rect.getRightBottome().getY()<<")"<<endl;
        }
        return 0;
    }
    

      

    作者:7oDo

    仅供参考,请勿抄袭。

    Hang Hang Hang !!!

  • 相关阅读:
    Delphi 控件使用谷歌浏览器控件chromium 安装包是 dcef3-20140522 --碰到的问题
    salesforce零基础学习(九十九)Git 在salesforce项目中的应用(vs code篇)
    Salesforce LWC学习(二十) CLI篇:新版本不支持Audience解决方案
    Salesforce LWC学习(十九) 针对 lightning-input-field的label值重写
    apt安装后需要移除的问题
    mysql 触发器阻止不合理数据插入
    本机环境virtualbox出现问题重装
    php 版本升级后需要对代码进行兼容性检测
    k8s使用需认证的私服仓库
    无法启动electron,提示node_modules/electron/dist/chrome-sandbox is owned by root and has mode 4755.
  • 原文地址:https://www.cnblogs.com/Jie-Fei/p/9096494.html
Copyright © 2011-2022 走看看