zoukankan      html  css  js  c++  java
  • bzoj2763 [JLOI2011]飞行路线

    [JLOI2011]飞行路线

    Time Limit: 10 Sec Memory Limit: 128 MB

    Description

    Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

    Input

    数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
    第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)
    接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)

    Output

    只有一行,包含一个整数,为最少花费。

    Sample Input

    5 6 1

    0 4

    0 1 5

    1 2 5

    2 3 5

    3 4 5

    2 3 3

    0 2 100

    Sample Output

    8

    HINT

    对于30%的数据,2<=n<=50,1<=m<=300,k=0;

    对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;

    对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.



    这可能是个分层图。。。其实就是dp啦 可能这个dp实在是有点特殊,所以就用最短路直接把答案给跑出来啦233
    
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn = 111299;
    struct lpl{
    	int to, dis;
    }lin;
    vector<lpl> point[maxn];
    int n, m, k, s, t;
    int a[50005], b[50005], c[50005], dis[maxn];
    bool vis[maxn];
    
    inline int num(int i, int t) {return (t - 1) * n + i;} 
    
    inline void connect(int A, int B, int C) {lin.dis = C; lin.to = B; point[A].push_back(lin);}
    
    inline void spfa()
    {
    	int now; queue<int> q; 
    	memset(dis, 0x3f, sizeof(dis));
    	q.push(s); vis[s] = true; dis[s] = 0;
    	while(!q.empty()){
    		now = q.front(); q.pop();
    		for(int i = point[now].size() - 1; i >= 0; --i){
    			lin = point[now][i];
    			if(dis[lin.to] > dis[now] + lin.dis){
    				dis[lin.to] = dis[now] + lin.dis;
    				if(!vis[lin.to]) q.push(lin.to);
    			}
    		} 
    		vis[now] = false;
    	}
    	printf("%d", dis[(k - 1) * n + t]);
    }
    
    int main()
    {
    	scanf("%d%d%d%d%d", &n, &m, &k, &s, &t); k++;
    	for(int i = 1; i <= m; ++i) scanf("%d%d%d", &a[i], &b[i], &c[i]);
    	for(int i = 1; i <= k; ++i) 
    		for(int j = 1; j <= m; ++j)
    			connect(num(a[j], i), num(b[j], i), c[j]), connect(num(b[j], i), num(a[j], i), c[j]);
    	for(int i = 1; i < k; ++i)
    		for(int j = 1; j <= n; ++j)
    			connect(num(j, i), num(j, i + 1), 0);
    	for(int i = 1; i < k; ++i)
    		for(int j = 1; j <= m; ++j)
    			connect(num(a[j], i), num(b[j], i + 1), 0), connect(num(b[j], i), num(a[j], i + 1), 0);
    	spfa();
    	return 0;
    }
    
    
    心如花木,向阳而生。
  • 相关阅读:
    Redux React-redux 理解
    React ---- 浅谈ReactJs
    javascript --- 鼠标事件
    javaScript --- localStorage 本地存储
    javascript -- 对象(深拷贝、浅拷贝)
    javascript --- 数组输出数组中最大值最小值差值
    Css中未知 div 宽高度,水平垂直居中方法
    Windows下使用NCL(Cygwin模拟Linux环境)
    Qt加载网页(加载浏览器插件)和制作托盘后台运行(南信大财务报账看号)
    OpenGL超级宝典第5版&&GLSL法线变换
  • 原文地址:https://www.cnblogs.com/LLppdd/p/9126321.html
Copyright © 2011-2022 走看看