zoukankan      html  css  js  c++  java
  • HDU1240 Asteroids! BFS

    Asteroids!

    Problem Description

    You're in space.
    You want to get home.
    There are asteroids.
    You don't want to hit them.

    Input

    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

    A single data set has 5 components:

    Start line - A single line, "START N", where 1 <= N <= 10.

    Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

    'O' - (the letter "oh") Empty space

    'X' - (upper-case) Asteroid present

    Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

    Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

    End line - A single line, "END"

    The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

    The first coordinate in a set indicates the column. Left column = 0.

    The second coordinate in a set indicates the row. Top row = 0.

    The third coordinate in a set indicates the slice. First slice = 0.

    Both the Starting Position and the Target Position will be in empty space.

    Output

    For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

    A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

    A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

    Sample Input

    START 1
    O
    0 0 0
    0 0 0
    END
    START 3
    XXX
    XXX
    XXX
    OOO
    OOO
    OOO
    XXX
    XXX
    XXX
    0 0 1
    2 2 1
    END
    START 5
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    0 0 0
    4 4 4
    END

    Sample Output

    1 0
    3 4
    NO ROUTE

      一道简单的三维题,思路应该是比较简单的。
      代码如下:
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <queue>
    using namespace std;
    
    char map[15][15][15], hash[15][15][15];
    
    int sx, sy, sz, ex, ey, ez;
    
    void gchar( char &c )
    {
    	while( c= getchar(), c!= 'O'&& c!= 'X' ) ;
    }
    
    struct Node
    {
    	int x, y, z, step;
    }info;
    
    int dir[6][3]= { 1, 0, 0, -1, 0, 0, 0, 1, 0, 0, -1, 0, 0, 0, 1, 0, 0, -1 };
    
    bool BFS( int &ans )
    {
    	memset( hash, 0, sizeof( hash ) );
    	info.x= sx, info.y= sy, info.z= sz, info.step= 0;
    	hash[sx][sy][sz]= 1;
    	queue< Node >q;
    	q.push( info );
    	while( !q.empty() )
    	{
    		Node pos= q.front();
    		q.pop();
    		if( pos.x== ex&& pos.y== ey&& pos.z== ez )
    		{
    			ans= pos.step;
    			return true;
    		}
    		for( int i= 0; i< 6; ++i )
    		{
    			int x= pos.x+ dir[i][0], y= pos.y+ dir[i][1], z= pos.z+ dir[i][2], step= pos.step+ 1;
    			if( map[x][y][z]== 'O'&& !hash[x][y][z] )
    			{
    				info.x= x, info.y= y, info.z= z, info.step= step;
    				hash[x][y][z]= 1;
    				q.push( info );
    			}
    		}
    	}
    	return false;
    }
    
    int main()
    {
    	int N, ans;
    	while( scanf( " START %d", &N )!= EOF )
    	{
    		memset( map, 0, sizeof( map ) );
    		for( int k= 1; k<= N; ++k )
    		{
    			for( int i= 1; i<= N; ++i )
    			{
    				for( int j= 1; j<= N; ++j )
    				{
    					gchar( map[k][i][j] );
    				}
    			}
    		}
    		scanf( "%d %d %d %d %d %d", &sy, &sz, &sx, &ey, &ez, &ex );
    		sx+= 1, sy+= 1, sz+= 1, ex+= 1, ey+= 1, ez+= 1;
    		scanf( " END" );
    		if( BFS( ans ) )
    		{
    			printf( "%d %d\n", N, ans );
    		}
    		else
    		{
    			puts( "NO ROUTE" );
    		}
    	}
    }
    

  • 相关阅读:
    翻转单词顺序
    java layout 表格项增加、删除、修改
    Hadoop学习之HBase
    protected的一些功能
    hdu4431 Mahjong
    kendo ui gird温馨提示(使用本地数据) 一个
    TOP计划猿10最佳实践文章
    Java高级应用(一个)-文件夹监控服务
    BSD介绍
    获取编译学习笔记 (十三)—— 外部中断
  • 原文地址:https://www.cnblogs.com/Lyush/p/2132486.html
Copyright © 2011-2022 走看看