zoukankan      html  css  js  c++  java
  • Hdoj 1253.胜利大逃亡 题解

    Problem Description

    Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

    魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

    img

    Input

    输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

    特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

    Output

    对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

    Sample Input

    1
    3 3 4 20
    0 1 1 1
    0 0 1 1
    0 1 1 1
    1 1 1 1
    1 0 0 1
    0 1 1 1
    0 0 0 0
    0 1 1 0
    0 1 1 0
    

    Sample Output

    11
    

    Author

    Ignatius.L


    思路

    依然是bfs,只是这种情况下每次扩展的状态是6种(因为有6个方向)

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int d[6][3]= {{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
    int a,b,c,t;
    int maps[55][55][55];
    int vis[55][55][55];
    
    
    struct node
    {
        int x;
        int y;
        int z;
        int step;
    };
    
    
    int judge(int x,int y,int z)
    {
        if(x>=0 && x<a && y>=0 && y<b && z>=0 && z<c && maps[x][y][z]==0 && vis[x][y][z]==0)
            return 1;
        else
            return 0;
    }
    
    int bfs()
    {
    
        if(maps[a-1][b-1][c-1]==1)
            return -1;
        memset(vis,false,sizeof(vis));
        queue<node> q;
        node now,next;
        now.x = 0;
        now.y = 0;
        now.z = 0;
        now.step = 0;
    
        vis[now.x][now.y][now.z] = true;
        q.push(now);
        while(!q.empty())
        {
            now=q.front();
            q.pop();
            for(int i=0; i<6; i++)
            {
                next.x = now.x + d[i][0];
    			next.y = now.y + d[i][1];
    			next.z = now.z + d[i][2];
    			next.step = now.step + 1;
    
                if(next.x==a-1 && next.y==b-1 && next.z==c-1 && next.step<=t)
                        return next.step;
    
                if(judge(next.x,next.y,next.z))
                {
                        vis[next.x][next.y][next.z]=1;
                        q.push(next);
    
                }
            }
        }
        return -1;
    }
    
    int main()
    {
        int testcase;
        scanf("%d",&testcase);
        while(testcase--)
        {
    
            scanf("%d%d%d%d",&a,&b,&c,&t);
            for(int i=0;i<a;i++)
                for(int j=0;j<b;j++)
                    for(int k=0;k<c;k++)
                        scanf("%d",&maps[i][j][k]);
            int ans = bfs();
            cout << ans << endl;
        }
        return 0;
    }
    
  • 相关阅读:
    12个Web开发者应该掌握的Firebug技巧
    sql语句修改表结构
    从数据库中查询数据
    收发短信API
    日志12.03
    监听短信数据库变化
    漫谈C语言及如何学习C语言(转)
    阅读短信
    在src文件中寻找短信数据库表
    拦截短信示例1
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9896999.html
Copyright © 2011-2022 走看看