zoukankan      html  css  js  c++  java
  • Nexus-vPC基础实验

    一、实验拓扑:

    由于条件有限,使用两个N5K做基本的vPC实验,Peer Keepalive Link使用的是两个Nexus 5K的Mgm0接口。

    二、配置步骤:
    1、先构建vPC domain,并在domain下定义role优先级、system优先级、PKL。
    2、然后配置Port-channel作为PL。
    3、配置vPC成员端口,配置vPC。
    4、配置Catalyst4500X交换机的Port-channel。

    N5K-1
    hostname N5K-1

    feature telnet
    feature interface-vlan
    feature lacp
    feature vpc

    vlan 1, 10
    vrf context management

    vpc domain 10   
      peer-switch >>>>对于其他的SW,看到的是同一个MAC地址?
      role priority 100  >>>这个值需要不同,小的成为Primary,大的成为Secondary,如果一样,小的MAC成为Primary
      system-priority 2100 >>>这个值在同一个domain需要配置为一致
      peer-keepalive destination 172.16.1.2 source 172.16.1.1
      delay restore 150

    interface Vlan10
      no shutdown
      ip address 10.1.1.1/24

    interface port-channel10
      switchport mode trunk
      switchport trunk allowed vlan 1,10
      spanning-tree port type network
      speed 10000
      vpc peer-link

    interface port-channel20
      switchport mode trunk
      vpc 20

    interface Ethernet1/1
      switchport mode trunk
      switchport trunk allowed vlan 1,10
      channel-group 10 mode active

    interface Ethernet1/5
      switchport mode trunk
      switchport trunk allowed vlan 1,10
      channel-group 10 mode active

    interface Ethernet1/9
      switchport mode trunk
      speed auto
      channel-group 20 mode active

    interface mgmt0
      vrf member management
      ip address 172.16.1.1/24

    N5K-2
    hostname N5K-2

    feature telnet
    feature interface-vlan
    feature lacp
    feature vpc

    vlan 1, 10
    vrf context management

    vpc domain 10  
      peer-switch
      role priority 101
      system-priority 2100
      peer-keepalive destination 172.16.1.2 source 172.16.1.1
      delay restore 150

    interface Vlan10
      no shutdown
      ip address 10.1.1.1/24

    interface port-channel10
      switchport mode trunk
      switchport trunk allowed vlan 1,10
      spanning-tree port type network
      speed 10000
      vpc peer-link

    interface port-channel20
      switchport mode trunk
      vpc 20

    interface Ethernet1/1
      switchport mode trunk
      switchport trunk allowed vlan 1,10
      channel-group 10 mode active

    interface Ethernet1/5
      switchport mode trunk
      switchport trunk allowed vlan 1,10
      channel-group 10 mode active

    interface Ethernet1/9
      switchport mode trunk
      speed auto
      channel-group 20 mode active

    interface mgmt0
      vrf member management
      ip address 172.16.1.1/24

    C4500-X

    vlan 1,10
    interface vlan10
      ip address 10.1.1.3 255.255.255.0
    interface range tenGigabitEthernet 1/1 , tenGigabitEthernet 1/3
      channel-group 20 mode active
    interface Port-channel 20  switch mode trunk
      vpc 20

    ......

    好好学习,天天向上!
  • 相关阅读:
    Asp.Net Core 3.1 使用Autofac Aop
    Abp中的工作单元UnitOfWork的Aop是如何实现的
    Asp.Net Core 3.1 Api 集成Abp项目AutoMapper
    Asp.Net Core 3.1 Api 集成Abp项目动态WebApi
    php限制登录次数
    vbs小实例
    php导出数据到excel
    mysqli单例模式连接数据库
    微信JsApi支付
    HTML5新增表单控件
  • 原文地址:https://www.cnblogs.com/MomentsLee/p/9904910.html
Copyright © 2011-2022 走看看