zoukankan      html  css  js  c++  java
  • HDU 4649 Professor Tian (概率DP)

    Professor Tian

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 870    Accepted Submission(s): 479


    Problem Description
    Timer took the Probability and Mathematical Statistics course in the 2012, But his bad attendance angered Professor Tian who is in charge of the course. Therefore, Professor Tian decided to let Timer face a hard probability problem, and announced that if he fail to slove the problem there would be no way for Timer to pass the final exam.
    As a result , Timer passed.
    Now, you, the bad guy, also angered the Professor Tian when September Ends. You have to faced the problem too. The problem comes that there is an expression and you should calculate the excepted value of it. And the operators it may contains are '&' (and),'|'(or) and '^'(xor) which are all bit operators. For example: 7&3=3, 5&2=0, 2|5=7, 4|10=14, 6^5=3, 3^4=7.
    Professor Tian declares that each operator Oi with its coming number Ai+1 may disappear, and the probability that it happens is Pi (0<i<=n).
     
    Input
    The input contains several test cases. For each test case, there is a integer n (0<n<=200) in the first line.In the second line, there are n+1 integers, stand for {Ai}. The next line contains n operators ,stand for {Oi}. The forth line contains {Pi}.
    Ai will be less than 220, 0<=Pi<=1.
     
    Output
    For each text case, you should print the number of text case in the first line.Then output the excepted value of the expression, round to 6 decimal places.
     
    Sample Input
    2 1 2 3 ^ ^ 0.1 0.2 2 8 9 10 ^ ^ 0.5 0.78 1 1 2 & 0.5
     
    Sample Output
    Case 1: 0.720000 Case 2: 4.940000 Case 3: 0.500000
     
    Source
     
    Recommend
    zhuyuanchen520

    题目大意

    初始有一个数字A0, 然后给出A1,A2..An共n个数字,这n个数字每个数字分别有一个操作符,&,|,^

    且每个数字出现的概率是pi

    如果某个数字出现了,那么就和前面的数字用它的操作符进行位运算。

    问最终的期望值是多少?

    思路

    这题官方题解说是反状态压缩,还是第一次做这种题。

    知道了怎么表示状态这题就觉得不难做了,赛后1A。

    题解官方的已经很详细了,不再累赘:

    反状态压缩——把数据转换成20位的01来进行运算

    因为只有20位,而且&,|,^都不会进位,那么一位一位地看,每一位不是0就是1,

    这样求出每一位是1的概率,再乘以该位的十进制数,累加,就得到了总体的期望。

    对于每一位,状态转移方程如下:

    f[i][j]表示该位取前i个数,运算得到j(0或1)的概率是多少。

    f[i][1]=f[i-1][1]*p[i]+根据不同运算符和第i位的值运算得到1的概率。

    f[i][0]同理。

    初始状态:f[0][0~1]=0或1(根据第一个数的该位来设置)

    每一位为1的期望 f[n][1]

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<vector>
    #include<map>
    using namespace std;
    
    typedef long long int64;
    const int INF = 0x3f3f3f3f;
    const int MAXN = 210;
    
    int n, m;
    double f[MAXN][2];
    int A[MAXN];
    char O[MAXN];
    double p[MAXN];
    
    int main(){
    
        char op[10];
        int cas = 1;
        while(~scanf("%d", &n)){
            
            for(int i=0; i<=n; ++i)
                scanf("%d", &A[i]);
    
            for(int i=1; i<=n; ++i){
                scanf("%s", op);
                O[i] = op[0];
            }
    
            for(int i=1; i<=n; ++i)
                scanf("%lf", &p[i]); 
    
            for(int i=0; i<20; ++i)
                f[0][0] = (A[i]>>i)&1;
    
            double ans = 0;
            for(int i=0; i<20; ++i){
                f[0][1] = (A[0]>>i)&1;
                f[0][0] = !f[0][1];
    
                for(int j=1; j<=n; ++j){
    
                    // 第j个数字不出现,0和1的概率
                    f[j][0] = f[j-1][0] * p[j];
                    f[j][1] = f[j-1][1] * p[j];
    
    
                    // 加上出现第j个数字,0和1的概率
                    if(O[j] == '^'){
                        if( (A[j]>>i) & 1 ){
                            f[j][0] += f[j-1][1]*(1-p[j]);
                            f[j][1] += f[j-1][0]*(1-p[j]);
                        } else{
                            f[j][0] += f[j-1][0]*(1-p[j]);
                            f[j][1] += f[j-1][1]*(1-p[j]);
                        }
    
                    } else if(O[j] == '&'){
                        if( (A[j]>>i) & 1 ){
                            f[j][0] += f[j-1][0]*(1-p[j]);
                            f[j][1] += f[j-1][1]*(1-p[j]);
                        } else{
                            f[j][0] += (f[j-1][0] + f[j-1][1]) * (1-p[j]);
                           // f[j][1]: 如果用了第j个数,这里不能出现1
                        }
                    } else if(O[j] == '|'){
                        if( (A[j]>>i) & 1){
                           // f[j][0]: 不能出现这种情况
                            f[j][1] += (f[j-1][0] + f[j-1][1]) * (1-p[j]);
                        } else{
                            f[j][0] += f[j-1][0] * (1-p[j]); 
                            f[j][1] += f[j-1][1] * (1-p[j]);
                        }
                    }
                }
                ans = ans + f[n][1] * (1<<i);
            }
    
            printf("Case %d:
    %.6f
    ", cas++, ans);
    
        }
        return 0;
    }
  • 相关阅读:
    探讨SQL Server并发处理存在就更新七种解决方案
    集合随机打乱
    订单并发5000的排队机制
    10款面向HTML5 画布(Canvas)的JavaScript库
    抽象类和接口的区别以及使用场景(记)
    常用的正则表达式
    webview加载url出现空白页面,有些页面没问题
    SQL常用语句
    Android Studio 简单介绍和使用问题小结
    Android中获取应用程序(包)的信息-----PackageManager的使用(一)
  • 原文地址:https://www.cnblogs.com/Ritchie/p/5460939.html
Copyright © 2011-2022 走看看