zoukankan      html  css  js  c++  java
  • POJ 1008 Maya Calendar / UVA 300【日期转换/常量数组】

    Maya Calendar
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 82431 Accepted: 25319
    Description

    During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

    For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

    Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

    1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

    Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

    Haab: 0. pop 0

    Tzolkin: 1 imix 0
    Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
    Input

    The date in Haab is given in the following format:
    NumberOfTheDay. Month Year

    The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
    Output

    The date in Tzolkin should be in the following format:
    Number NameOfTheDay Year

    The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
    Sample Input

    3
    10. zac 0
    0. pop 0
    10. zac 1995
    Sample Output

    3
    3 chuen 0
    1 imix 0
    9 cimi 2801
    Source

    Central Europe 1995
    【题意】:第一个为 Haab 一年365天,共19个月,前18个月的名字pop, no, zip, zotz, tzec, xul... 每个月20天 ,0 ~ 19,最后的名字是uayet, 这个月只有5天, 0~ 5。
    第二个为Tzolkin 一年260天,他们用20个英文和13个数字组合来表示每一天。20个英文依次是:imix, ik, akbal,···年初几天的描述如下:1 imix, 2 ik, 3 akbal
    【分析】: 不同计年方法之间的转化思路是:根据各自计年方法的定义,将一种计年方法换算成总天数,再将总天数转化为令一种计年方法。
    可先将两个日历月份的名字用常量数组存储起来,然后求第一个日历的天数,转换为第二个即可;
    【代码】:

    #include<cstdio>
    #include<string>
    #include<cstdlib>
    #include<cmath>
    #include<iostream>
    #include<cstring>
    #include<set>
    #include<queue>
    #include<algorithm>
    #include<vector>
    #include<map>
    #include<cctype>
    #include<stack>
    #include<sstream>
    #include<list>
    #include<assert.h>
    #include<bitset>
    #include<numeric>
    #define debug() puts("++++")
    #define gcd(a,b) __gcd(a,b)
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define fi first
    #define se second
    #define pb push_back
    #define sqr(x) ((x)*(x))
    #define ms(a,b) memset(a,b,sizeof(a))
    #define sz size()
    #define be begin()
    #define pu push_up
    #define pd push_down
    #define cl clear()
    #define lowbit(x) -x&x
    #define all 1,n,1
    #define rep(i,n,x) for(int i=(x); i<(n); i++)
    #define in freopen("in.in","r",stdin)
    #define out freopen("out.out","w",stdout)
    using namespace std;
    typedef long long LL;
    typedef unsigned long long ULL;
    typedef pair<int,int> P;
    const int INF = 0x3f3f3f3f;
    const LL LNF = 1e18;
    const int maxn = 1e3 + 20;
    const int maxm = 1e6 + 10;
    const double PI = acos(-1.0);
    const double eps = 1e-8;
    const int dx[] = {-1,1,0,0,1,1,-1,-1};
    const int dy[] = {0,0,1,-1,1,-1,1,-1};
    const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    
    int d,i,y;
    string m,mm;
    string a[] = { "pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen", "yax", "zac", "ceh", "mac", "kankin", "muan", "pax", "koyab", "cumhu", "uayet" };
    string b[] = { "imix", "ik", "akbal", "kan", "chicchan", "cimi", "manik", "lamat", "muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau" };
    int main()
    {
        int n;
        cin>>n;
        cout<<n<<endl;
        while(n--)
        {
            scanf("%d.",&d);
            cin>>m>>y;
            int sum=0;
            for(i=0;i<19;i++)
            {
                if(a[i] == m) //对应月份数字
                {
                    break;
                }
            }
            sum = (y*365) + (i*20) + d; //总天数
            y = sum / 260; //年
            m = b[sum%20]; //数字映射字符串
            d = sum%13+1; //日,从1开始所以+1
            cout<<d<<' '<<m<<' '<<y<<endl;
        }
        return 0;
    }
    /*
    3
    10. zac 0
    0. pop 0
    10. zac 1995
    
    3
    3 chuen 0
    1 imix 0
    9 cimi 2801
    
    /*
    
    which had 19 months. Each of the first 18 months was 20 days long,
    The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4.
    
    the names of the months
    pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu
    
    18*20+1*5=365
    ----
    
    the days of the months were denoted by numbers starting from 0 to 19.
    The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4.
    
    The year was divided into thirteen periods, each 20 days long.
    
    Each day was denoted by a pair consisting of a number and the name of the day.
    They used 20 names:
    imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau
    and 13 numbers; both in cycles.
    
    13*20=260
    */
    */
    
  • 相关阅读:
    atitit...触发器机制 ltrigger mechanism sumup .的总结O8f
    atitit. 集合groupby 的实现(2)---自定义linq查询--java .net php
    atitit. groupby linq的实现(1)-----linq框架选型 java .net php
    atitit.j2ee 1.5 1.6 的不同跟 Servlet 3.0新特性总结
    Atitit. 常用街机系统and 模拟器总结 snk neo geo cps mame sfc smc
    atitit. access token是什么??微信平台公众号开发access_token and Web session保持状态机制
    atitit.二进制数据无损转字符串网络传输
    atitit.压缩算法 ZLib ,gzip ,zip 最佳实践 java .net php
    Atitit.现实生活中最好使用的排序方法-----ati排序法总结
    atitit.修复xp 操作系统--重装系统--保留原来文件不丢失
  • 原文地址:https://www.cnblogs.com/Roni-i/p/9278674.html
Copyright © 2011-2022 走看看