zoukankan      html  css  js  c++  java
  • HDU 1686 Oulipo / POJ 3461 Oulipo / SCU 2652 Oulipo (字符串匹配,KMP)

    HDU 1686 Oulipo / POJ 3461 Oulipo / SCU 2652 Oulipo (字符串匹配,KMP)

    Description

    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

    Input

    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

    Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

    Sample Input

    3
    BAPC
    BAPC
    AZA
    AZAZAZA
    VERDI
    AVERDXIVYERDIAN

    Sample Output



    Http

    HDU:https://vjudge.net/problem/HDU-1686
    POJ:https://vjudge.net/problem/POJ-3461
    SCU:https://vjudge.net/problem/SCU-2652

    Source

    字符串匹配,KMP

    解决思路

    直接运用KMP算法解题,请看我的这篇文章

    代码

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    const int maxN=10001;
    const int maxM=1000001;
    const int inf=2147483647;
    
    int n,m;
    char W[maxN];
    char T[maxM];
    int F[maxN];
    
    int main()
    {
    	int TT;
    	cin>>TT;
    	for (int ti=1;ti<=TT;ti++)
    	{
    		scanf("%s",W);
    		scanf("%s",T);
    		n=strlen(W);
    		m=strlen(T);
    		F[0]=-1;
    		for (int i=1;i<n;i++)
    		{
    			int j=F[i-1];
    			while ((W[j+1]!=W[i])&&(j!=-1))
    			    j=F[j];
    			if (W[j+1]==W[i])
    			    F[i]=j+1;
    			else
    			    F[i]=-1;
    		}
    		int i=0,j=0;
    		int Ans=0;
    		while (i<m)
    		{
    			if (W[j]==T[i])
    			{
    				i++;
    				j++;
    				if (j==n)
    				{
    					Ans++;
    					j=F[j-1]+1;
    				}
    			}
    			else
    			if (j==0)
    				i++;
    			else
    				j=F[j-1]+1;
    		}
    		cout<<Ans<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    android:background背景图片被拉伸问题
    面试积累(String和StringBuffer, StringBuilder的理解)
    面试积累(冒泡排序和选择排序)
    面试积累(java的内存分析)
    面试积累(java配置环境变量)
    异常积累(SQLException)
    【linux】fdisk磁盘分区
    【走马观花】十一月十八日通州雨
    【linux】CentOS查看硬件信息
    【linux】go安装及配置
  • 原文地址:https://www.cnblogs.com/SYCstudio/p/7196103.html
Copyright © 2011-2022 走看看