zoukankan      html  css  js  c++  java
  • JAVA 大数 A+B问题

    A + B Problem II

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

    Sample Input

    2
    1 2
    112233445566778899 998877665544332211

    Sample Output

    Case 1:
    1 + 2 = 3
    
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110

    代码:

    import java.io.BufferedInputStream;
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {
    
    	public static void main(String[] args) {
    		// TODO 自动生成的方法存根
    		Scanner str = new Scanner(System.in);
    		int T;
    		T=str.nextInt();
    		int i=1;
    		
    
    		for(i=1;i<=T;i++)
    		{
    			BigInteger a=str.nextBigInteger();
    			BigInteger b=str.nextBigInteger();
    			System.out.println("Case "+i+":");
    			System.out.println(a+" + "+b+" = "+a.add(b));
    			if(i<T)
    			{
    			System.out.println("");
    			}
    			
    		}
    
    	}
    
    }
    
  • 相关阅读:
    Spring Boot
    Spring Boot – Jetty配置
    如何使ESLint在Visual Studio 2019和2017中工作: 2019 v16和2017> = v15.8
    CentOS 7 安装 Nginx
    HTTPS-使用Certbot自动配置Let’s Encrypt证书
    centos7升级内核到最新版本
    [C#.net]Connection Timeout和Command Timeout
    Redis中切换db
    Redis 模糊查询删除操作
    [Abp vNext 源码分析]
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781751.html
Copyright © 2011-2022 走看看