zoukankan      html  css  js  c++  java
  • [解题报告]HDU 1013 Digital Roots

    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 35288    Accepted Submission(s): 10794


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     
    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     
    Output
    For each integer in the input, output its digital root on a separate line of the output.
     
    Sample Input
    24 39 0
     
    Sample Output
    6 3
     
    Source
     
     
     
     
     
     
     
     
     
    如果你一开始把所有的值设置为int型,恭喜你,你会得到一个WA

    接着你大概会改成unsigned型,恭喜你,你会得到一个超时

    比如这样:

    #include<stdio.h>
    unsigned fun1(unsigned i)
    {
        unsigned j,temp;
        for(j=1;j<i;j*=10)
        {
            if(i>j&&i<=j*10)
            {
                temp=j;
            }
        }
        unsigned sum=0;
        while(i)
        {
            sum+=i%10;
            i/=10;
        }
        return sum;
    }
    int main()
    {
        unsigned n;
        while(scanf("%u",&n)!=EOF&&n)
        {
            while(n>=10)
            {
                n=fun1(n);
            }
            printf("%u\n",n);
        }
        return 0;
    }
    然后你终于恍然大悟,用字符串!!
     
    #include <stdio.h>
    int main()
    {
    char s[1000];
    int i,sum;
    while(scanf("%s",s)!=EOF)
    {
          if(s[0]=='0')
           {
             break;
            }
          sum=0;
       for(i=0;s[i]!='\0';i++)
        {
          sum+=s[i]-'0';
        if(sum>9)
        {
         sum=sum%10+sum/10;
        }
        }
        printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    windows中echo的用法
    通过phpMyAdmin写入MySQL,获取webshell
    底部小鱼特效
    kali Linux的简单介绍
    Kali安装gmpy2
    利用kali生成字典的三种方式
    利用kali嗅探HTTP网页用户账户密码
    永恒之蓝(ms017-010)漏洞利用
    如何使用最新Microsoft Edge打开Flash页面
    结对第二次作业
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2960340.html
Copyright © 2011-2022 走看看