zoukankan      html  css  js  c++  java
  • 10115 Automatic Editing

    Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

    Rule Find Replace-by
    1. ban bab
    2. baba be
    3. ana any
    4. ba b hind the g

    To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

    For example, suppose we start with the line

    banana boat

    and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

      Before After
      banana boat babana boat
      babana boat bababa boat
      bababa boat beba boat
      beba boat behind the goat

    The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

    Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

    The first test case in the sample input below corresponds to the example shown above.

    Example input:

    4
    ban
    bab
    baba
    be
    ana
    any
    ba b
    hind the g
    banana boat
    1
    t
    sh
    toe or top
    0
    

    Example output:

    behind the goat
    shoe or shop
    

     这题就是字符窜替换,替换规则给出,然后将对应的字符串进行替换掉就可以了,我偷工减料,直接就用现成的STL吧,惭愧,现在才完成到这里,呵呵,慢慢来吧,有些事不能强求,尽力就好

    运行情况:

    #include<iostream>
    #include<vector>
    #include<string>
    #include<algorithm>
    #include<cstdio>
    //#include "boost/foreach.hpp"
    using namespace std;
    
    int main()
    {
    	int i;
    	vector<string> v1,v2;
    	string str;
    	while(cin>>i)
    	{
    		getchar();
    		if(!i) break;
    		v1.clear();
    		v2.clear();
    		while(i--)
    		{
    
    			getline(cin,str,'\n');
    			v1.push_back(str);
    			getline(cin,str,'\n');
    			v2.push_back(str);
    		}
    		getline(cin,str,'\n');
    //		BOOST_FOREACH(string s,v1){
    //			cout<<"r:"<<s<<endl;
    //		}
    
    		unsigned index = 0;
    		while(index<v1.size())
    		{
    
    			string::iterator strIt = search(str.begin(),str.end(),v1[index].begin(),v1[index].end());
    			if(strIt!=str.end())
    			{
    				str.replace(strIt,strIt+v1[index].length(),v2[index]);
    				continue;
    			}
    			index++;
    		}
    		cout<<str<<endl;
    
    	}
    
    	return 0;
    }
    
    
    
  • 相关阅读:
    ASP.NET MVC5 实现网址伪静态
    用c#中的WebBrowser抢小米F码,抢小米手机以及自动测试实现原理
    MVC授权
    使用grid++report打印选中行
    对Spring.Net+NHibenate+Asp.Net Mvc+Easyui框架的个人认识
    hibernate+spring+mvc+Easyui框架模式下使用grid++report的总结
    一个关于Linq对引用类型元素集合去重问题的思考
    Spring MVC PageNotFound.noHandlerFound No mapping found for HTTP request with URI
    ueditor 1.4.3.2 独立/单独 上传图片框原理
    (兼容IE6)又一个提示框思密达,腾讯UED 201401242352
  • 原文地址:https://www.cnblogs.com/UnGeek/p/2560601.html
Copyright © 2011-2022 走看看