zoukankan      html  css  js  c++  java
  • 【树形dp】Farmcraft

    题目

    In a village called Byteville, there are houses connected with N-1 roads. For each pair of houses, there is a unique way to get from one to another. The houses are numbered from 1 to . The house no. 1 belongs to the village administrator Byteasar. As part of enabling modern technologies for rural areas framework, computers have been delivered to Byteasar's house. Every house is to be supplied with a computer, and it is Byteasar's task to distribute them. The citizens of Byteville have already agreed to play the most recent version of FarmCraft (the game) as soon as they have their computers. Byteasar has loaded all the computers on his pickup truck and is about to set out to deliver the goods. He has just the right amount of gasoline to drive each road twice. In each house, Byteasar leaves one computer, and immediately continues on his route. In each house, as soon as house dwellers get their computer, they turn it on and install FarmCraft. The time it takes to install and set up the game very much depends on one's tech savviness, which is fortunately known for each household. After he delivers all the computers, Byteasar will come back to his house and install the game on his computer. The travel time along each road linking two houses is exactly 1 minute, and (due to citizens' eagerness to play) the time to unload a computer is negligible. Help Byteasar in determining a delivery order that allows all Byteville's citizens (including Byteasar) to start playing together as soon as possible. In other words, find an order that minimizes the time when everyone has FarmCraft installed.


    mhy 住在一棵有n个点的树的1号结点上,每个结点上都有一个妹子。 mhy从自己家出发,去给每一个妹子都送一台电脑,每个妹子拿到电脑后就会开始安装zhx牌杀毒软件,第i个妹子安装时间为Ci。 树上的每条边mhy能且仅能走两次,每次耗费1单位时间。mhy送完所有电脑后会回自己家里然后开始装zhx牌杀毒软件。 卸货和装电脑是不需要时间的。 求所有妹子和mhy都装好zhx牌杀毒软件的最短时间。

    Input

    The first line of the standard input contains a single integer N(2<=N<=5 00 000) that gives the number of houses in Byteville. The second line contains N integers C1,C2…Cn(1<=Ci<=10^9), separated by single spaces; Ci is the installation time (in minutes) for the dwellers of house no. i. 
    The next N-1 lines specify the roads linking the houses. Each such line contains two positive integers a and b(1<=a<b<=N) , separated by a single space. These indicate that there is a direct road between the houses no. a and b.

    Output

    The first and only line of the standard output should contain a single integer: the (minimum) number of minutes after which all citizens will be able to play FarmCraft together.

    Sample Input

    6 1 8 9 6 3 2 1 3 2 3 3 4 4 5 4 6

    Sample Output

    11

    HINT

    Explanation: Byteasar should deliver the computers to the houses in the following order: 3, 2, 4, 5, 6, and 1. The game will be installed after 11, 10, 10, 10, 8, and 9 minutes respectively, in the house number order. Thus everyone can play after 11 minutes. If Byteasar delivered the game in the following order: 3, 4, 5, 6, 2, and 1, then the game would be installed after: 11, 16, 10, 8, 6, and 7 minutes respectively. Hence, everyone could play only after 16 minutes,

    题解:

    设f[x]为x的子树中全部安完软件的时间,对于x节点的a,b儿子,设他们的子树大小为siz[a],siz[b],显然遍历一遍子树a的时间就是2*siz[a],然后分类讨论

    若先走a,后走b,那么f[x]=max(f[a]+1,f[b]+2siz[a]+1) 若先走b,后走a,那么f[x]=max(f[a]+2siz[b]+1,f[b]+1)

    对于f[a]+1和f[b]+1我们可以不用考虑,那么如果先走a更优,当且仅当:

    f[b]+2siz[a]+1<f[a]+2siz[b]+1

    转移

    f[a]-2siz[a]>f[b]-2siz[b]

    那么直接将x的儿子按照f[i]-2siz[i]排序,先走f[i]-2siz[i]的就好了

    Attention!!:根节点的软件是最后安装的,所以要特判,ans=max(2*(n-1)+1+time[1],f[1])

    代码

    (有些丑不要介意)

    #include <cstdio>
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    const int maxn=500010;
    int n,cnt;
    int to[maxn<<1],next[maxn<<1],head[maxn],v[maxn],p[maxn],f[maxn],siz[maxn];
    void add(int a,int b){
        to[cnt]=b,next[cnt]=head[a],head[a]=cnt++;
    }
    bool cmp(int a,int b){
        return f[a]-2*siz[a]>f[b]-2*siz[b];
    }
    void dfs(int x,int fa){
        int i,sum=0;
        siz[x]=1;
        for(i=head[x];i!=-1;i=next[i])
            if(to[i]!=fa)
            dfs(to[i],x),siz[x]+=siz[to[i]];
        p[0]=0;
        for(i=head[x];i!=-1;i=next[i])
            if(to[i]!=fa)
                p[++p[0]]=to[i];
        sort(p+1,p+p[0]+1,cmp);
        if(x!=1)f[x]=v[x];
        for(i=1;i<=p[0];i++)
            f[x]=max(f[x],f[p[i]]+sum+1),sum+=2*siz[p[i]];
    }
    int main(){
        scanf("%d",&n);
        int i,a,b;
        memset(head,-1,sizeof(head));
        for(i=1;i<=n;i++)    scanf("%d",&v[i]);
        for(i=1;i<n;i++)    scanf("%d%d",&a,&b),add(a,b),add(b,a);
        dfs(1,0);
        printf("%d",max(f[1],2*(siz[1]-1)+v[1]));
        return 0;
    }
  • 相关阅读:
    华为云发送邮件
    activiti act_re_model 分析
    tengine upstream
    zuul压力测试与调优
    idea 快捷键
    kubernetes helm
    编写高质量代码–改善python程序的建议(二)
    编写高质量代码--改善python程序的建议(一)
    总结OpenvSwitch的调试经验
    提高SDN控制器拓扑发现性能
  • 原文地址:https://www.cnblogs.com/Vocanda/p/12654721.html
Copyright © 2011-2022 走看看