zoukankan      html  css  js  c++  java
  • poj 3280 Cheapest Palindrome

                                                                                                  Cheapest Palindrome
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 8643   Accepted: 4189

    Description

    Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

    Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

    FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

    Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

    Input

    Line 1: Two space-separated integers: N and M 
    Line 2: This line contains exactly M characters which constitute the initial ID string 
    Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

    Output

    Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

    Sample Input

    3 4
    abcb
    a 1000 1100
    b 350 700
    c 200 800

    Sample Output

    900

    Hint

    If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
    题意:给定一个长度为M的字符串,字符串里只出现N个给定的英文字母,可以删减或增加字符串里的字符(删减或增加某个字符都相应的需要消耗资金),使得字符串成为一个回文数,有很多的改法,要从中选取一种改法,使得消费最小化
    思路:动态规划,定义dp[i][j]数组,含义:将原字符串里编号i到j的子字符串变换成回文数的耗费的最小资金。
    则dp[i][j]=min(dp[i+1][j]+cost[s[i]-'a'],dp[i][j+1]+cost[s[j]-'a']);其中cost数组记录着删除或增加某个英文字母的资金(取删除这个字符或者增加这个字符需要消耗资金的最小值)那么dp[i][j]取min{去掉首字母的子列成为回文数消耗的最小资金+子列成为回文数的基础上删掉这个首字母或者末尾加上这个首字母使得当前序列成为回文数消耗的最小资金,……};
    AC代码:
    #include<iostream>
    #include<algorithm>
    #include<string>
    using namespace std;
    const int M_MAX = 2000;
    int dp[M_MAX+1][M_MAX+1],cost[27];
    int main() {
        int N, M;
        while (cin >> N>>M) {
            memset(dp,sizeof(dp),0);
            string s;
            //getline(cin, s);
            cin >> s;
            for (int i = 0;i < N;i++) {
                char c;int delete_cost, add_cost;
                cin >> c>>add_cost>>delete_cost;
                 cost[c - 'a']=min(add_cost,delete_cost);
            }
            for (int i = M-1;i>=0;i--) {
                for (int j = i+1;j < M;j++) {
                    if (s[i] == s[j]) {
                        dp[i][j] = dp[i + 1][j - 1];
                    }
                    else dp[i][j] = min(dp[i+1][j]+cost[s[i]-'a'],dp[i][j-1]+cost[s[j]-'a']);
                    
                }
            }
            cout << dp[0][M - 1] << endl;
        }
        return 0;
    }
     
     
  • 相关阅读:
    2016某天闲谈
    APP测试入门篇之APP基础知识(001)
    windows服务器下frp实现内网穿透
    nginx使用与配置
    spring boot 实现优雅的关闭
    spring boot 自定义sql分页查询
    java获取类加载路径和项目根路径的5种方法
    linux下 启动node 和关闭node
    docker 安装 fastdfs
    docker 常用命令和常用容器启动
  • 原文地址:https://www.cnblogs.com/ZefengYao/p/5871329.html
Copyright © 2011-2022 走看看