zoukankan      html  css  js  c++  java
  • poj2352树状数组

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0

    Hint

    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
    题意:给你一串坐标,找左下方的星星数
    题解:树状数组,x方向处理,因为是从y方向递增的
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<iomanip>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const double g=10.0,eps=1e-9;
    const int N=15000+5,maxn=32000+5,inf=0x3f3f3f3f;
    
    int s[maxn],num[maxn];
    
    void add(int i,int x)
    {
        while(i<=maxn){
            s[i]+=x;
            i+=i&(-i);
        }
    }
    int sum(int i)
    {
        int ans=0;
        while(i>0){
            ans+=s[i];
            i-=i&(-i);
        }
        return ans;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
     //   cout<<setiosflags(ios::fixed)<<setprecision(2);
        int n,x,y;
        while(cin>>n){
            memset(num,0,sizeof num);
            memset(s,0,sizeof s);
            for(int i=1;i<=n;i++)
            {
                cin>>x>>y;
                int te=sum(x+1);
                num[te]++;
                add(x+1,1);
            }
            for(int i=0;i<n;i++)cout<<num[i]<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    redis几种数据类型以及使用场景
    Ubuntu16.04安装redis和php的redis扩展
    详细透彻解读Git与SVN的区别(集中式VS分布式)
    bootstrap轮播如何支持移动端滑动手势
    vue添加cnzz统计访问量
    el-tabs值修改时更新路由参数值
    Vue ,elementUI,dropdown组件中command方法添加额外参数的方法
    vue页面滚动监听
    mintui tabbar底部跳转页面
    vue 引入bootstrap
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6758350.html
Copyright © 2011-2022 走看看